WRT54G 2.04.3 7/26/2004

Discussion in 'Cisco/Linksys Wireless Routers' started by jdepew, Jul 27, 2004.


Firmware Functionality

  1. Works very well

  2. Works well but some issues

    0 vote(s)
  3. Works occassionally

    0 vote(s)
  4. Serious problems but some parts work

    0 vote(s)
  5. Firmware crashes device

    0 vote(s)
  1. jdepew

    jdepew Administrator Staff Member Member


    Linksys, A division of Cisco Systems, Inc.
    Product: WRT54G
    Classification: Firmware Release History
    Firmware Date: 7/1/2004
    Release Date: 7/21/2004
    Last Firmware Version: 2.04.3
    Firmware 2.04.3
    - Resolves issue with disabling firewall
    - Added QoS function
    - Added Port Triggering function
    - Added L2TP option for WAN connection type
    - Added ability to back up and restore configuration files
    - Added Wireless isolation function
    - Added ability to filter internal NAT redirection
    - Added ability to restrict access to web GUI from wireless clients
    - Added ability to filter IDENT port 113
    - Resolves issue with HeartBeat WAN connection
    - Added support for 40/56bit cipher to support old browsers to use https
    - Resolves issue with PPTP passthrough
    - Changed WPA Group Key renewal time range to 600~7200 seconds
    - Added IGMP proxy support
    - Added ability to allow web GUI access only through https or http

    Firmware 2.02.2
    - Updated wireless driver to support all versions of WRT54G hardware
    - Adds support to allow WAP54G connect as a repeater
    - CTS protection mode set to disable by default to improve wireless performance in normal environments
    - Resolved issue where the WLAN LED stays on even when wireless is disabled
    - Resolved security vulnerability causing the web server in the router to crash

    Firmware 2.00.8 (WRT54G v.2 only)
    - Updated wireless driver

    Firmware Version 1.42.2
    - Updated wireless driver to 3.31.15
    - Added URL and contents filters
    - Added L2TP passthrough
    - Added HeartBeat Signal support
    - Resolved issue with Connect on Demand

    Firmware Version 1.41.2
    - Updated GUI format and layout

    Firmware Version 1.30.7
    - Adds UI control to enable/disable frame bursting
    - Resolves issue with firmware upgrade error in Internet Explorer 6.0.2800.1106.xpsp2.030422-1633, on Windows XP pro.
    - Send to disable DynDNS
    - Resolves issue with using the 4th tx key for WEP
    - Resolves issue with disconnecting PPPoE causing WPA to be disabled

    Firmware Version 1.30.1
    - Adjust PPTP max MTU value from 1400 to 1460
    - The router is now certifiable for the UPnP logo
    - Complies with final 802.11g standard
    - Improved performance asymmetry between the transmit and receive paths
    - Receive Broadcast packets from renew state. Some DHCP server (Dlink 300G+) send broadcast ACK after it receives a REQUEST
    - Fix: The firmware upgrade will fail, if DDNS updates while upgrading
    - Fix: If first DNS address fails, the second or third DNS address will be used to resolve domain names
    - Added the following items under Setup Page:
    - Router Name
    - Manual Time Server
    - MAC Clone
    - wireless domain
    - Security Settings
    - Added the following items under System Page
    - UPnP enable/disable
    - Ping Test and Traceroute
    - Added the following items under Wireless Page
    - CTS Protection Mode
    - Basic Rate
    - Added the following items under Status Page
    - Router Name
    - Start IP Address
    - End IP Address
    - Added Wi-Fi Protected Access(TM) support including AES and TKIP encryption
    - Resolves issue with Port Forwarding name showing up as garbage characters
    - Added "B-Only" option to wireless modes
    - Added "Default" option to Basic Rate settings

    Firmware Version 1.02.1
    - Incorporates updates found in the Draft IEEE 802.11g version 6.1 specification
    - Resolves interoperability issues with legacy 802.11b devices under Mixed Mode
    - Resolves a performance bug where the performance in a mixed b, g network did not go up once the last b client disassociated
    - Resolves issue where WEP degrades performance
    - Resolves issue with TZO DDNS Service
    - "Domain Name" replaces "name"
    - TFTP server will only verify image file name "xxxx.bin"
    - MAC Address Filter under the Advanced tab works on both wired and wireless clients
    - Fixed a bug that prevented wireless clients from connecting to the Internet if there was no active wired PC (PPoE customers in Europe and China only)
    - Support for UPnP enabled applications such as MSN Messenger
    - Fixed a bug that caused computers connected to the LAN ports to be dropped at some interval only to be immediately re-connected
    - Fixed Dynamic Routing issue between 2 Routers
    - Allows User to name Static Route Configurations
    - Modified PC List Web Page to avoid confusion
    - Stabilized Wireless-G to LAN and WAN Throughput
    - Stabilized Wireless-B to LAN and WAN Throughput
    - Improved LAN-WAN Throughput

    Firmware Ver.: 1.01
    - Initial release
  2. Morac

    Morac Network Guru Member

    Signal Issues

    I'll mention that installing this firmware can result in lowered signal quality and slower speeds.

    This has been confirmed by a number of people including myself. When I tested it installing the 2.04.3 firmware resulted in a 7% drop in signal strength and a 25% drop in signal quality. Downgrading back to 2.02.7 fixes this problem.

    There are other people reporting this issue at Broadband Reports.

    I'd recommend contacting LinkSys if you have this problem, because when I did so I was told
    Assuming the double negative is not intended, this means Linksys is unaware of the problem. The support person said she would forward my complaint to the engineering department, but it would be better if many people reported the same issue to raise it's priority.
  3. Esquire

    Esquire Mesquire Staff Member Member

    A case of very bad grammar [​IMG]
  4. mrid

    mrid Network Guru Member

    I cannot seem to get a DHCP offer with this firmware...any suggestions?
  5. gjvogt

    gjvogt Guest

    Like others this firmware upgrade has resulted in significant performance degradation. Thanks to this site, I learned about the Sveasoft firmware and am now running it with much better results.
  6. I'm using the hyper firmware 1.0 which is a mod of this version except it has 13 channels and 48mw power.

    I'm having this problem where I cannot start 2 different msn's on the computer well it only works on my wireless connection and not my wired one. Is anyone else having this problem. It seems to be a problem with the nat redirection or Upnp not working well.. If anyone can confirm it would be good.
  7. Lorphos

    Lorphos Network Guru Member

    QoS not working

    QoS is not working as I was hoping. I have a 3072/384 DSL line and I want to limit my uploads so that they don't affect downloads.
    No matter what setting I used (300kbps, 340, 384, auto), whenever I have both an upload and a download going, the download rates drop dramatically.

    Has anybody else had more success?
  8. bradtem

    bradtem Network Guru Member

    2.04.3 completely hosed my wrt54g

    I was doing some firmware upgrading. Tried a file called Sartori which when run said it was Samhadi, but had trouble with it -- it wouldn't change the device's IP address from the factory default. So after a few tries at factory reset I figured I might as well go "back" to the official firmware, but the latest version, and uploaded 2.04.3 to it via the web browser. The upload completed, and it got to the success page, but after that -- death.

    By death I mean that when the router boots, you can bing it from 2 seconds after boot until about 11 seconds after boot, with rather odd random response times on the pings (from a few ms to a whole second.) Then it stops responding to pings or anything else.

    Attempts to upload firmware with the tftp utility during this window get to 95% and hang, and can no longer talk to the device.

    The first tech supporter person was an idiot, the 2nd a bit smarter but in spite of advice to cycle through 5 iterations of 20 second depresses of the reset button, still no luck leaving this state. So I will return it for RMA as that is the only way to get it to life without opening it up.

    However, I am curious if anybody has experience of what I did wrong. Is it forbidden to load in external firmware and then try to switch back to a newer version of the factory? I had been running 2.02.1 (I think) for a long time before trying the sveasoft. I also tried an alternate called NewBroadcom -- was that the source of my doom?

    Annoying because when I get the thing back I want to get the fancy firmware features, and am going to be a bit gun-shy.
  9. valkyrie

    valkyrie Network Guru Member

    I could check every box except works very well. :cry:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice