WRT54G 2.2 needed power-off

Discussion in 'HyperWRT Firmware' started by martin_b, Jul 24, 2007.

  1. martin_b

    martin_b LI Guru Member

    After having flashed to Thibor 15c and for the first time runnning a wireless connection for about a week, suddenly this morning, I couldn't connect to the WLAN.

    I then tried connecting via cable to the router's setup, but couldn't reach the page, it just said: "No web site is configured at this address.". This is the same message I get when trying to go to the setup-page from a wireless connection. But in my case, I was connected via cable.

    I then unplugged the power, plugged it back in, and I could then connect to the setup, and after that, I could succesfully establish a wireless connection, and things are back to normal again. I wonder when I will have to unplug the power next time?

    Anyone else experiencing this behaviour?
  2. ifican

    ifican Network Guru Member

    Ocassionally things hang up, relates to anything computer related and in life. Heck my ipod even freezes from time to time. What i am getting at is this is nothing to be concerned with until it becomes chronic or regular. An occasional lockup can be do to lots of different things but in my experience with networking equipment is generally heat related. Keep an eye on it and if it continues we can dig into things to try to help determine what the issue is.
  3. martin_b

    martin_b LI Guru Member

    Ok. Thanks anyway. I am perfectly familiar with things in computers from time to time seem to just freeze occasionally; even my phone crashes once in a while.

    What I'm getting at is this: the WLAN on the router, with stock linksys firmware, was practically useless, but worked like a charm with Thibor 15c and the output transmission wattage bumped to 80%. Point is that the router has never ever "hung" before, just didn't work with wireless.
    Does upping the wattage generate more heat? I read somewhere on this forum, that it doesn't.
  4. ifican

    ifican Network Guru Member

    Absolutely, but you can get around this by using small heatsinks stuck to whatever components you need to cool. More crude ways are to put a fan blowing on the case, open the case (which will cool it some immediately because it lets transient heat out, and or blow a fan on the open case. Easiest in my opinion for the long term is to put the heatsinks and close the case back up.
  5. martin_b

    martin_b LI Guru Member

    It has happened two times since i wrote my initial post here. I just had to unplug the power again. The router isn't even close to being hot, and it's sitting in a cold room. Could the router have been damaged by the upping of the wattage?
  6. ifican

    ifican Network Guru Member

    yes but unlikely, the case may not be hot enough to cause you any alarm, its the chipsets that you need to be concerned with. That is if heat is what is causing you grief.
  7. Thibor

    Thibor Super Moderator Staff Member Member

    type the following into the command window "nvram set cpu_overdrive=1;nvram commit" without the quotes, or type the 2 commands in one at a time without the semi-colon
    there is a memory timing error that affects the Gv2.2's and causes them to reboot. this will fix it by raising the cpu frequency to 216Mhz.
  8. ka9yhd

    ka9yhd LI Guru Member

    Yes most definetly.... If you push the output power up then the heat generated also goes up.
  9. martin_b

    martin_b LI Guru Member

    Are we talking about one of these scripts, or are we talking about a telnet prompt? And will it remember this setting?
  10. mstombs

    mstombs Network Guru Member

    Its a one-off set of commands, enter via Telnet or through the web screen 'run command'.

    This is a permanent change saved to nvram - unless you "clear nvram reset to defaults".

    You will also need to reboot for the new setting to take effect
  11. martin_b

    martin_b LI Guru Member

    Thanks. I'll give it a try when i get to work tomorrow.
  12. martin_b

    martin_b LI Guru Member

    And here I am, friday afternoon, and it seems to work now. Thanks for all your help guys!

    Btw, should I be worried about cooling when I have raised the CPU frequency? What are your experiences?
  13. mstombs

    mstombs Network Guru Member

    I wouldn't be unduly worried about temperature - this small overclock was actually done by Linksys firmware for this version - and I notice that Tomato also overclocks my WRT54GS 1.1 without even asking

    Jan  1 00:00:17 wrt54gs user.warn kernel: CPU: BCM4712 rev 1 at 216 MHz
    Jan  1 00:00:17 wrt54gs user.warn kernel: Calibrating delay loop... 215.44 BogoMIPS
  14. martin_b

    martin_b LI Guru Member

    And today, monday, the WLAN isn't accessible again, and the router seems to think that "No website is configured at this address" when trying to access the config page. I bet everything works againg after a reboot.

    Any ideas? It doesn't seem to be a cooling issue, since the router isn't remotely hot, and it isn't even doing any routing. It used to be used as the main router, and back then it was much warmer than it is now, but still showed the same symptoms as it is now.
  15. martin_b

    martin_b LI Guru Member

    Is it possible to set the router to reboot automatically every, say, 24 hours?
  16. mstombs

    mstombs Network Guru Member

    I am sure it is, you can use the init script to create a cron job to execute the reboot command when you want to. See this thread for an example of such a scripts, I assume you can modify to trigger the file every day rather than 15 mins the cron parameters were set to here.


    But it seems like a sledge hammer to crack a nut - we don't seem to have gotten to the bottom of your original problem. As I recall the problem that the cpu_overdrive flag is meant to fix is the router crashing and rebooting on large file transfers - you seem to just have the web server on the router crashing?

    I don't recall ever seeing a "No website is configured at this address" I assume this message is actually generated by your browser not the router.
  17. martin_b

    martin_b LI Guru Member

    You're right. I haven't experienced the problem with the router crashing during large file transfers. And indeed the cpu_overdrive-fix doesn't seem to have helped with my problem.

    I'm pretty sure that the "No website is configured at this address"-message is not generated by the browser - this text message is from the router.

    When this problem arises I can't get a LINK to the router via WLAN, but I can get this message when I try to access the web interface via cabled LAN.
    Sometimes, though, I can connect to the web interface via cable under these circumstances if I instead of typing "" simply type "" (ie. without the "http://"). Then I can reboot and then WLAN works perfect again. It has been up for almost 2 days now since the last reboot.

    edit: btw, the "No website is configured at this address"-message is the same message I get when trying to connect to the web-interface via WLAN when I have disabled WLAN-acces to the web-interface.
  18. martin_b

    martin_b LI Guru Member

    And now, after an uptime of 0 days, 22:28:24, I lost wireless connection to the accesspoint. I could connect to the webinterface via cable the moment efter I lost wireless connection, but the interface was kind of slow, and I had to try a couple of times to go to the different config tabs without seeing the message "The connection was reset".
    Do you think a change to DD-WRT would help?
  19. mstombs

    mstombs Network Guru Member

    Only you can judge whether dd-wrt works for you. I often recommend Hyperwrt-Thibor as a safe first step into 3rd party firmware as it just adds to the Linksys web screens - and has very few known bugs, I used it exclusively for over a year.

    Tomato replaces these with an emphasis of fast and simple, but adds jffs and overnight wireless off functions I find useful (and under the bonnet is still based on Linksys code) as well as interesting bandwidth monitors. dd-wrt is more powerful but may be regarded over the top if you don't want to use the extra functionality, and openwrt is for purists, didn't have a web gui at all till recently...

    Assuming you haven't got a real hardware problem it seems there is something incompatible about your setup, maybe in the broadcom binary wireless modules? Are you using the latest version of drivers on your PC (yes I know they shouldn't be able to kill the router...)? Different firmwares may just work better, only you can judge - just be very particular about resetting the nvram variables when changing - rogue variables can cause unforeseen problems.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice