WRT54G admin panel scrwd

Discussion in 'Cisco/Linksys Wireless Routers' started by m6246, Dec 14, 2005.

  1. m6246

    m6246 Network Guru Member

    I bought a WRT54G wireless router last week, worked perfectly but when going to and logging in it showed me this..


    So today I went back to the store and I got a new one, but it has the SAME PROBLEM!

    So whats with this?! The shows

    Firmware Version:v1.00.1 , Sep 20 2005
    Boot Version:1.01.2

    11g RF Status:enabled(HW)
    11g RF Firmware Version:
    11g RF Domain:DE(channel 1~13)
    11g RF Channel:11
    11g RF SSID:VG01

    ----- Dynamic Information

    11g RF Mac Address:00:14:BF:B1:35:8C
    LAN Mac Address:00:14:BF:B1:35:8A
    WAN Mac Address:00:14:BF:B1:35:8B
    Hardware version:1.0
    Device Serial No.:CDFB0EAR4106

    So maybe I need a firmware upgrade? But this has to be done through the admin panel, which I dont have?

    Also, does CodePattern:WGV5 mean I have a version 5 router?
  2. NateHoy

    NateHoy Network Guru Member


    You have a V5. My condolences.

    You can see what version you have by looking at the serial number. If the serial number starts in CDFB, then you have a V5. The SysInfo page you posted has a serial number starting in CDFB on the page AND has the WGV5 pattern.


    I'd go to the Linksys page, and find the TFTP client for the V5 series and the latest firmware, and do a firmware update using that method. They are up to at least 1.0.3 now, if I recall. It could also be that the V5's don't like your web browser - what web browser and operating system are you using?

    The other thing you can do is call Linksys - I think they are exchanging the V5 units for V3 units on request, and all you pay is shipping for your V5. That way, you have more memory, and can play with third party stuff if you choose. If you prefer the V5, then by all means go for it. But I'd exchange it. ;)
  3. gaster

    gaster Network Guru Member

    I sometimes have that problem but I hit refresh and it's fine then.
  4. m6246

    m6246 Network Guru Member

    refreshing doesnt work, im using Firefox but using Internet Explorer gives the same result. Same goes for Windows XP / MacOS X..

    Could you please describe the steps / give links to downloads cause im not into this and I dont want to break things (if its even possible to break it more.. damn). Anyways, much appreciated!
  5. NateHoy

    NateHoy Network Guru Member

    First step (which may fix your problem anyway). Unplug the router. Press the RESET button and hold it. Plug in the router. Continue holding the RESET button for at least 30 seconds. Check to see if problem is solved. If not, you're at least back to Linksys defaults and a known good base state.

    Next, try turning off any and all firewalls you may be running on your client. Maybe those are interfering with the web pages on the WRT54G. Obviously, disconnecting the WRT54G from the Internet is probably a good idea while you get this all set up. ;)

    If that doesn't help...

    Go to www.linksys.com, and under "Support", select "Downloads". From the pulldown list, select "WRT54G V5". You'll see the latest firmware, which is 1.00.4.

    I assume, but I'm not sure, that the Linksys TFTP client can access the V5's. If so, download the TFTP client (search around on these forums and you'll find it). That's the way to push a firmware update to a router that can't get the Web interface running.

    You may also need to call Linksys. The V5 uses a closed-source VXWORKS operating system, so the inner workings are a bit more of a mystery than the V4 and prior units, which used Linux and had the firmware source code available.
  6. m6246

    m6246 Network Guru Member

    thanks man, you just made my day!

    resetting didnt work, however the firmware upgrade did!

    thanks a bunch :thumbup:
  7. NateHoy

    NateHoy Network Guru Member

    No problem. Enjoy.
  8. gaogi

    gaogi Network Guru Member

    DO NOT DO THIS! Holding the reset button while plugging in the power will put the router into Management mode. This is a safe mode for uploading firmwares only. The proper way to reset the router is to hold the reset button with the power plugged in. Holding it for 30 seconds does nothing more than reset the router several times. It's good enough to hold it until the Power light starts to flash.

    If you put your router into Management mode, you can just power cycle the router to get it working again. Although if you try to log in too fast (within the first few seconds of boot up), you'll still see the Management screen. Just hit refresh, and the regular GUI should come up.
  9. NateHoy

    NateHoy Network Guru Member

    gaogi -

    OK, I wasn't aware of that one. Thanks.

    However, there are several tests that have been done here in terms of holding the RESET button for 30 seconds.


    Holding it for the 5 seconds or so until the power light flashes does NOT reset the NVRAM. It only resets factory settings. Holding it for the full 30 seconds will force a full NVRAM wipe followed by a restart.

    I didn't realize that holding the RESET button during power-up would cause a switch into "management" mode - so if that is bad information I apologize for the confusion. That's pretty common advice here, though, from what I've seen. Thanks for the clarification.
  10. gaogi

    gaogi Network Guru Member

    Management mode only applies to v.5 routers. Resetting the router in this way has no effect on previous versions, so I can see how people would try to do this on v.5 and accidentally getting into this mode and not know what to do.
  11. NateHoy

    NateHoy Network Guru Member

    AH! OK, thank you for that bit. I'll try to keep that in mind when V5'ers ask for assistance. Thank you very much.
  12. m6246

    m6246 Network Guru Member

    true, I got the Management mode which allowed me to upload new firmware. I tried to upload the downloaded 1.04 firmware however it didnt seem to have uploaded succesfully as it still stated it was v1.01 after restarting the router.

    so I tried upgrading using the TFTP tool, which worked.
  13. NateHoy

    NateHoy Network Guru Member

    So I gave you the right advice, but only out of sheer ignorance and coincidence. LOL!

    Hey, all's well that ends well. Glad you have a working router.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice