WRT54G Alchemy Remote SSH won't work

Discussion in 'Sveasoft Firmware' started by ChrisN, Jun 22, 2005.

  1. ChrisN

    ChrisN Network Guru Member


    I have just upgraded from Satori to Alchemy. The upgrade went very well however I am not able to get a remote SSH connection. Internally works great but I can not access it remotely.

    I believe the settings are the same from the two setups (Firewall off) port forword port 22 to but can seem to access.

    I doubt very much this is an issue with ISP blocking ports as the problem occurred only after upgrading. I am a little nervous going back to Satori as I have heard of problems in reflashing.

    Any help is greatly appreciated
  2. malfeasance

    malfeasance Network Guru Member

    Port Forwarding


    You don't even have to forward the port! But, you do have to set SSHD on and specify the port on the Administration page. I use an unusual port number, because people are always trying to get in on port 22. Look through /etc/services and find something that isn't being used and use it instead if you want - that's what I do. Also, for other routers behind the AP where I do have to forward, I use something unusual.

    Firewall off: hmmm...
  3. redlynx

    redlynx Network Guru Member

    It depends on witch device you want to connect.

    If you want to ssh on your Linksys router, like malfeasance said, you don’t need to forward anything inside your LAN. If you want to ssh on your PC inside your local network, where you have a ssh server listening, then you should forward ssh port to that specific ip.

    Try a port > 1024, because I had the same problem with ssh when connecting from Internet, my ISP was blocking port 22.

    So, don’t forget to change your listening port on your Linksys box or on your PC and to specify same port on your client application (putty, tunnelier…).
  4. denkedranjoe

    denkedranjoe Network Guru Member

  5. denkedranjoe

    denkedranjoe Network Guru Member


    at first..sorry for my english ;-)

    I have the same problem, too.
    I use a lancom router to share my internet connection.
    Now i want to administrate a computer in my network remote via rdp.
    I want to tunnel this session over ssh.

    So i bought a WRT54g, installed the latest Alchemy firmware, set SSHD on
    and forwarded the ssh port from the Lancom Router
    to the WR54g (Lancom Port : 4711; WRT54G Port: 4711)

    I also turned the firewall off.

    But I am not able to establish a SSH connection over the Internet.

    Any ideas why this doesnt work ?
    Thanks in advance


    P.S. the WRT54G is connected to the Lancom Switch via Uplink - Not via WAN Port.
  6. adnan938

    adnan938 Network Guru Member

    Same problem here.
    I've got a WRT54GS v2.2 running Alchemy V1.0.
    SSH connects fine internally, but from the WAN port it won't connect at all. I also disabled the firewall and allowed anonymous internet requests, but still no can do. Even tried connecting a spare PC to the WAN port and SSH from there :-(

    This is annoying enough that I am looking for another firmware to use. Too bad really, it's an awesome firmware otherwise. Maybe this is Sveasoft's way of telling us to pay for their upgrade, sort of a "shareware restriction".

  7. adnan938

    adnan938 Network Guru Member

    Problem solved...
    After much frustration, I switched to DD-WRT, and _STILL_ had the same problem. But then I enabled Remote Management and that solved everything. Should work with Sveasoft as well since DD-WRT is based on Sveasoft's Alchemy.

    My apoligies to Sveasoft for my previous comment.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice