WRT54G and weird XBOX 360 annoyances

Discussion in 'Networking Issues' started by SneakyDave, Nov 1, 2007.

  1. SneakyDave

    SneakyDave LI Guru Member

    This isn't a big problem with my WRT54G (version 2.0, stock linksys firmware v4.30.5), but its an annoying one.

    If I assign my (wireless) XBOX 360 a static IP, online games that check the router NAT tell me that the NAT is "moderate", or "strict", when they expect it to be "open". It only happens when I've manually assigned the IP.

    So when I let the router assign the XBOX its on IP address via DHCP, that resolves the gaming problem, but when I play play music from another PC through my xbox 360, I get a different problem. What happens is that after an hour or 2 of streaming music from a computer on the same network through the xbox 360, everything freezes, and I check the xbox network connections, and I find out that router has assigned it a strange IP number, something unlike 192.168.1.x, very strange. I have to restart the xbox to resolve it.

    So, what I've done is if I'm going to listen to music for a long time, I'll change the IP to static, and if I'm gaming, I'll leave it to DHCP to assign an IP.

    ---this is just more info, but probably due to a defective range expander--
    My other PC's don't seem to have this problem (wired or wireless), other than the fact that I also have a range expander (linksys, WRE54G), that interferes with a PC on the network, thinking that they both have the same IP, when in fact, they don't. The same error (this machine shares an IP with another machine on the network) appears whether I use DHCP or not. When I disconnect the range expander, the PC operates normally.

    So, I'm looking at tomato to see if the first problem can be resolved. Thanks for providing any input and providing a forum to discuss these linksys issues.

    I am using WEP (the range expander doesn't support WAP or WPA, or whatever the name is), and a unique broadcasted SSID on channel 6.
  2. cfinic

    cfinic LI Guru Member

    Hey, if you don't mind checking, does the Xbox get assigned an IP that's likee 164.x.x.x? Or what's the number it comes up with?
  3. SneakyDave

    SneakyDave LI Guru Member

    Yes, I'm almost positive that's the number it comes up, but I'll double check, and I update my first post to add the linksys router and firmware version).
  4. Toxic

    Toxic Administrator Staff Member

    when you assign a static IP address to the Xbox, are you assigning an IP outside of the DHCP range that the router assigns?

    I'm thinking that you maybe assigning an IP that the DHCP uses, and in two hours or whatever the router assigns the same IP to a wired or wireless client when it polls for DHCP.

    I am only guessing since you ahev not given me enough info to go on.

    why not assign a Static DHCP address from the router in Tomato firmware. this means the Xbox will always get the Same IP address (which should be outside of the DHCP range given in the routers setup)
  5. SneakyDave

    SneakyDave LI Guru Member

    Yes, for instance, my DHCP clients start at, I assign the xbox (and all non-DHCP wired and wireless adapters) in the range of 2-10.

    I thought the same thing, but luckily I only have 5 devices using the router, the range expander is using its default address of, the others use (DHCP assigned), (laptop), (Fedora Linux) and the xbox is (when I have it statically assigned, currently, the xbox is using via DHCP). So I can't see what kind of interference is going on.

    I'll try that when I install tomato, I don't think(?) I can do that with my current stock firmware from linksys, unless I misunderstand what you're saying. Are you saying that you specify a list of DHCP managed static IP's in tomato (say 101 for the xbox, etc.) and the xbox will always pick the one you choose for it.

    I can provide more information if you need it.

    I've had weird things happen with the range expander in the past, but I don't think its causing this problem, but who knows. I would expect it to be something with the router. I can't even open a browser up to the range expander's admin configuration ( although the link and network activity lights are blue and functioning.
  6. SneakyDave

    SneakyDave LI Guru Member

    Actually, its starts out like 169.255.x.x. I installed Tomato, didn't see any difference. I did notice that the range expander (defective?) was affecting the ability of other devices to connect via DHCP.

    The last thing I'm trying to get fixed is my Fedora 8 box working with the wireless system. I don't think its the card I'm using because both cards give the same reponse. DHCP won't assign an IP, but if I staticly assign an IP, it doesn't really "take", the machine still doesn't show up on the network, and doesn't have any network access.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice