WRT54G and wireless networking problem

Discussion in 'Networking Issues' started by brianw1967, Mar 18, 2005.

  1. brianw1967

    brianw1967 Network Guru Member

    Hello all, first time poster. I recently upgraded to a laptop and wireless router. I am unable to transfer large files (movies, .bin's etc). I have a desktop and a laptop, both w/WXP sp2. both machines see each other on the network and can view shared folders. I can xfer files of any size when I hook the laptop up to an ethernet cable fine. The problem comes in when I try to Xfer large files from my laptop to my desktop machine wirelessly. It goes for about a minute or so (no ryme or reason to timeout) and then it says cannot continue. The network dies for a second.

    I have tried adjusting the various channels w/no sucess. I went to the linksys chat and was told to change the mtu settings and I did. Also w/no luck. Any help is greatly appreciated.

    Security: WPA Pre-shared Key
    wpa algorithm:TKIP
    auth. type: auto
  2. Jogobo

    Jogobo Network Guru Member

    The only thing I can suggest is a step by step approach. First of all disable all security settings (WAP, MAC filter, firewall). Then try the transfer again. If not successfull try to set RTS threshold and fragmentation threshold to lower values. A good start would be 512 for RTS and fragmentation = MTU. Please let me know if any of these helped.
    If you are able to transfer large files successfully try to enable security step by step until transfer fails again. Then you most probably found the reason and you can ask whether there is a solution or workaround.

    BTW, do you have only 1 wireless client or more?

    Just my 2 €-cents.
  3. brianw1967

    brianw1967 Network Guru Member

    I tried all that you suggested and it appears that the wpa shared key is the culpret. Now, how do I protect my network and transfer files. Has anyone ever heard of the encryption being the problem? and if so, was it able to be fixed? Once again, thanx for any and all help, I greatly appreciate it..
  4. Jogobo

    Jogobo Network Guru Member

    I suggest you stick with WEP128 and MAC filter. And you should definitely inform Linksys about the WPA problem.
    I have similar problems with a WAG54G and a WAP54G. They only work together with WEP. Switching to WPA they don't connect.

    Still waiting for a firmware update which solves the problem though.

    Just my 2 €-cents.
  5. brianw1967

    brianw1967 Network Guru Member

    Thanks for the info. I tried that on the advise of a friend. The problem is that I still get bumped. I tried it w/mac filtering on and off and get bumped w/any encryption. So.. for now I will re-enable Wap and either hook up via wire for large files or just shut down encryption totally. I will most likely goto compussa and buy another wrt54g and see if the problem is the same. If so I'll return it and contact linksys. I want to rule out a bad router...
  6. Jogobo

    Jogobo Network Guru Member

    Did you try with RTS and fragmentation settings other than default?
  7. brianw1967

    brianw1967 Network Guru Member

    OK Jogobo, I think that was it. In my advanced wireless settings the default value set for:

    Frag Threshold == 2346
    Rts Threshold == 2347

    I changed it to:

    Frag Thresh == 2346
    RTS Thres == 2346

    I know that isn't much of a change but I wanted to start out small. Keep values same (not sure if they are supposed to be or need to be) But I was able to send an 800meg file from Desktop to laptop and then pull an 800 meg file from the laptop to desktop.

    Thankyou for sticking w/me on this. I greatly appreciate it...
  8. brianw1967

    brianw1967 Network Guru Member

    While I do appreciate your help I need to take back my last post. I am now having mixed results at transering files.
  9. Jogobo

    Jogobo Network Guru Member

    Again, set RTS Threshold to 512 and if you have stable transfers try increasing it slightly until transfers fail again. Then step back to last known good.

    Just my 2 €-cents.
  10. brianw1967

    brianw1967 Network Guru Member

    Hopefully this is my final post on this thread. Today (Sun) I went to CompUSA and purchased another wrt54g. Hooked it up, set the necessary wpa encryption. Went to my laptop and was able to upload files from the desktop. I suceeded twic in >800 meg files. I am now faily sure I can say the modem was faulty. I notice stronger signals from the new router. Even when located in the same place. It appears to connect faster wirelessly. So, anyone wannna buy a bad router? :)

    Special thanks to Jogobo for all your help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice