WRT54G bad flash

Discussion in 'Networking Issues' started by Hashss, May 25, 2010.

  1. Hashss

    Hashss Networkin' Nut Member

    My english is not very good, but i hope, you will understand the problem.

    Tried all the recovery methods.

    When I power it on, the power light blinks fast, after some time DMZ light comes on, stays on about 7 sec, then turns off, and this cycle repeats all over again.

    BUT the worst part: when I pin LAN cable in, there is no LAN port leds coming on! Also 'internet' port has the same problem.

    got router from a friend with all the faults. I do not know what he did with it. Visible defect on circuit is not.
    PC are saying "Network cable unplugged". Cable is not damaged. So I can't get any positive ping results!

    WRT54G v2.0
  2. mstombs

    mstombs Network Guru Member

    The light sequence suggests router is trying to boot and crashing, only a serial console log would confirm, but it does suggest the CFE bootloader is OK. Have you tried everything here:-


    Sometimes JTAG is the only way to clear nvram, which includes switch config items. Only follow guides that recommend flash chip shorting if you want to throw the thing away - can easily damage both the CPU and flash chip irreparably.
  3. Hashss

    Hashss Networkin' Nut Member

    Here is what exactly happened with router:
    1.note from friend: "I think I used Tomato on it at that time but it has been so long. It worked for over 2 years every day no problem and then just stopped."
    2. this is when i got it, and wired ports were already dead. But wireless was still in working condition.
    3. i somehow got username and password and through the wireless connection tried to reflash it with linksys original firmware, and there followed my biggest mistake: as soon i got web page opened on, I tried it to flash again! It was less than 20sec.
    4. Here it is: dead ports and dead wireless too. And as it have dead ports, I can't get any ping. As i said, even PC [win 7] says "Network cable unplugged"
    5. I tried everything: power cycle, hard reset. Yet I have not tried to smash against the wall.

    My conclusion so far: There is something wrong on hardware level, I think with chip Admtek ADM6996L, who is responsible about wired ports. This is just a guess.
  4. jaygyver

    jaygyver LI Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice