WRT54G basic problems in setting up

Discussion in 'Cisco/Linksys Wireless Routers' started by stevec, Aug 29, 2004.

  1. stevec

    stevec Network Guru Member

    Bought a Linksys WRT54G-EU due to demise of my old D-Link
    Set up as per instructions.
    Connects to internet Ok. Other non-linksys equipped laptops also
    connect through it

    -can't select a channel (drop down box is empty)
    -can't select "ad-hoc" or "infrastructure" (no switch !)
    -can't enable WEP (nowhere to enter a key !)
    -save settings button does't appear to work (page resets to defaults
    after saving page or changing pages, SSID won't change from default)
    -Worrying me is that other posters on these forums refer to buttons or
    options that i don't appear to have.

    Firmware is latest ( (?) via auto update)
    under Win XP.

    Can someone point me in the direction of a fix? I have looked
    at other forums/ sites and RTFM but can't find an answer.

    Any help appreciated.
  2. Toxic

    Toxic Administrator Staff Member

    did you reset router after upgrading?

    Press reset switch on back of router for 30 seconds which with set router to default settings. then enter router setup and setup router.
  3. stevec

    stevec Network Guru Member

    Thanks for replying Simon.

    Tried what you suggested but still no effect even after reset.

    -Still no channels in drop down box
    -Time zone relentlessly resets to US pacific
    -cannot see key space or means to change between ad-hoc & infrastructure
    - can't change password or SSID
    -save settings buttons don't seem to work (nor does "cancel")

    Firmware is (3rd Aug 2004)

    To sum up , some options aren't diplayed and the router won't permanently
    accept change. Amazingly it WORKS re: internet access , but I have little or no
    control how it does so.

    If this unit looks like a dud , I can change it but I'm curious to know whats happening.

    Thank you anyway Simon

  4. Esquire

    Esquire Mesquire Staff Member Member

    Stevec, there is no key or switch to alternate between ad hoc and infrastructure modes on the router - ad hoc mode does not apply to routers. If you wish to run ad hoc mode, configure it on each of your wireless clients and (optional) disable your router's wireless function.

    In any case, you may have a bad router since it will not accept your modifications - I came upon a similar problem not too long ago when I setup a new WRT54G for a friend. I would recommend you take your router back to the shop for an exchange - I did and the replacement unit has been working perfectly to this day.
  5. stevec

    stevec Network Guru Member

    A new router and still the same problems

    -can't save settings
    -changing password in setup locks me right out
    -this one won't even consider a firmware upgrade
    - setup seems to finish OK but something called "Gozilla" tries to write to the router and fails.

    It's as if the router settings were read only. I can get on the internet but only on US pacific time with no WEP.

    Even changed network card and network cables in my PC . No difference.
    Tried all manner of resets. No effect.

    I'm stumped as to what to do next. Is it possible to have 2 duds ?
    (serial nos are about 100 apart) CDF50D503826 , CDF50D503914
  6. fact

    fact Network Guru Member

    Maybe the browser you use to display the setup screens is at fault. Check for firewalls pop-up blockers spyware and the like.
  7. stevec

    stevec Network Guru Member

    Thanks Fact.
    In desperation I borrowed a friends router (Netgear).
    It set up with no problems , browser or otherwise (shame he wants it back).

    Looks like PC world have at least 2 duds in stock. I have posted the S/Ns
    previously. Thanks for everyones help but I despair of getting a fully functioning one.
    Shame , its a nice product otherwise.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice