WRT54G being slow/problems after removing power

Discussion in 'Cisco/Linksys Wireless Routers' started by jamieem, Feb 12, 2006.

  1. jamieem

    jamieem Network Guru Member

    Hi, I have a WRT54G v2, and I have the latest firmware. Yesterday, after downloading a bit too much (but not so much) I found that my internet was going really slow and lots of web pages would often time out. I then removed the internet going to the router and directly connected the internet to my computer and found it to be working perfectly fine. (My computer isn't wireless.) I then put the internet back to the router and found that the internet was slow and pages would time out again. However, I turned off the power to the router and modem overnight and found that everything is working okay... for now. What's with my router being slow after downloading a lot?

    Another thing is that whenever I shut off the power from the router, I find that I get NAT Errors on ports which previously worked before pulling the power. It's really common, too. (Moreso than the problem mentioned above.) What's up with that? Is there any way I can disconnect power from it properly or something?
  2. t4thfavor

    t4thfavor Network Guru Member

    there are many postings about this and it has to do with max connections and drop connection timeout.

    p2p opens up a shize load of connections and theytimeout slowly so do some homework...

    upgrade to third party firmware also
  3. jamieem

    jamieem Network Guru Member

    Sorry, it's just that I get confused with certain terms and stuff, but is this what you mean?:

    "The default firmware for Linksys (and all replacement firmwares except for one) have a severe problem where they track old connections for FIVE days, which causes the router to hang when using P2P apps, or any software that generates a lot of connections. DHT only aggravates the situation because of the number of connections it generates." -utorrent.com website

    Anyways, I'm using:
    Firmware Version : v4.30.1, HyperWRT 2.1b1 +tofu13c

    but I'm still getting NAT errors, and I am positive everything has been forwarded correctly because before I restarted the power to my router, the port was working.
  4. t4thfavor

    t4thfavor Network Guru Member

    bingo that solves the first problem
    put yourself in the dmz
  5. jamieem

    jamieem Network Guru Member

    That DMZ thing worked... thanks a lot for helping an idiot like me :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice