WRT54G - Bricked but I don't know why....

Discussion in 'Cisco/Linksys Wireless Routers' started by amagicbullet, Jul 17, 2005.

  1. amagicbullet

    amagicbullet Network Guru Member

    Ok, Im not to sure why my WRT54G is now bricked....
    I updated the firmware to 4.00.7 on my 1.1 router using a wired desktop with the bin file....so i could use my new wireless laptop (connection issues).... It worked worked fine i had a good update laptop connected, it was great.

    I then logged back into the router to see what was new, I looked a round and clicked on a security feature, it set for a sec after going to a new window. So i un-did the power and restarted it... Bricked! Power light just flashes...

    Idk if the firmware had a problem when i clicked the link or if i did something when i disconnected the power... But a few min after the restart my ssid changed names to linksys-(somenumbers) then i restared again and nothing... Bricked!

    I tryed ping -t it just times out

    I hav'nt tried shorting but i would think thats the next step... any input would go towards saving me 50$ for a new one...
  2. littlewhoo

    littlewhoo Network Guru Member

    And this will probably also be the last step. Because when shorting the pins, there is a high risk of damaging the hardware and bricking the router completely.

    Currently you have only a firmware problem, so the router is 100% recoverable by reflashing the firmware over a JTAG cable. you only have to build (or buy) a JTAG cable (~10$), attach it to your router and flash a proper firmware over JTAG.
  3. amagicbullet

    amagicbullet Network Guru Member


    Ok this does sound like a better alternative. I think i found my jtag location on my board, bottom left corner when leds are facing you. The only thing is... I have a v1.1 router not a v2 as indicated in the guide you linked to, totaly different board layout.... Will this still work or do you have any other alternatives?
  4. amagicbullet

    amagicbullet Network Guru Member

  5. jagboy

    jagboy Network Guru Member

  6. amagicbullet

    amagicbullet Network Guru Member

    Thanks, but no luck...

    I see that page jagboy but it is the same guide i posted previously, and i had no luck with it...

    Pinging it works just by pluging in the power and changing my nic settings....
    The 15/16 pin short does nothing that im aware of....
    Tftp fails, no connection...
    Linksys Firmware updater exe fails, no connection....
    I cant use Jtag since i have a v1.1 without the pins, just soulder points, not even going to try soldering...

    The ping works, so there must be a way....
    But, Im stumped....
  7. sebehk

    sebehk Network Guru Member

    I bricked it, too. :-(

    I did the same thing too. Loaded the 4.00.7 firmware onto my 54G v1.1 router. No problems in uploading.

    Looking around in the web utility, I saw the big SES icon. Curiously clicked on it. WHAM! My router goes bye-bye. Tried all debricking guides. No luck in reviving the router. I'm not going to waste time soldering, so it was easier to get a new one at Best Buy, got a 54G v2.0, uploaded the 3.06.3 firmware, and doing fine now. I'm gonna wait to load 4.00.7 until I see more people successfully using it.

  8. jagboy

    jagboy Network Guru Member

    4.00.7 is only for wrt54gSv2
  9. amagicbullet

    amagicbullet Network Guru Member

    Woah, thats it....

    sebehk thats exactly what i did.... i just couldnt remember that thing i clicked on... SES damn... yours did it to, well i guess linksys needs to fix there downloads page. I selected WRT54G and thats what it gave me, 4.00.7.... I guess im out of luck, then.
  10. tweak32

    tweak32 Guest

    If you can ping. You got a chance

    I had the same thing happen to me. Config light blinking, unable to reset, unable to log in through the web interface, man was I cursing. If you can still ping it try looking at Linksys's home page and download their autoupdater. It is an executable file that blasts it back to original firmware. Atleast it worked for me. If you cant ping, try changing from auto negotiate to 10-baseT Half dublex. Let me know how you make out.
  11. amagicbullet

    amagicbullet Network Guru Member


    I can ping after changing my settings....
    The autoupdater doesnt connect though...
    Read up above to see all that ive done.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice