WRT54G broadcasting wrong MAC address? Help!

Discussion in 'Cisco/Linksys Wireless Routers' started by phow4rd, Apr 5, 2005.

  1. phow4rd

    phow4rd Network Guru Member

    Have any of y'all ever seen this one?

    My WRT54G (v2.0) seems to be broadcasting the wrong MAC address.

    As I understand it, the Wireless MAC address should be one hex digit up from the wired one, right? So, if the one printed on the bottom is xx:xx:xx:xx:xx:B3, the wireless one should be xx:xx:xx:xx:xx:B4, no?

    The "Status" page on the admin utility seems to confirm this is the case; it clearly lists the MAC address as "...B4".

    But when I fire up a stumbler and go looking for it, the address I see is xx:xx:xx:xx:xx:B5!

    Normally, this wouldn't be a problem, but I'm trying to bridge to my new Airport Express, and if the addresses don't match, it no workee. :(

    Any ideas??
  2. Guyfromhe

    Guyfromhe Network Guru Member

    you can either set the B5 address as the address your using in your airport express, or you can install some custom f/w and change the wirless mac address with ifconfig.
  3. phow4rd

    phow4rd Network Guru Member

    Thanks for the suggestion, but it doesn't work. If I input "...:B5", the WRT54G doesn't accept the request to bridge to it, because it thinks it's address is "...:B4". Conversely, if I input "...:B4", the AE obviously won't even see a router to bridge to, because the WRT54G is broadcasting "...:B5". :(

    Actually, AFAIK, this type of network bridging isn't even possible without custom firmware.

    In fact, I didn't even notice the MAC address problem until after I'd already installed hyperwrt, played with it a bit, then installed sveasoft over it because I was able to find detailed AE-to-WRT54G bridging instructions on the net.

    Only after following said instructions, and failing to link the networks, did I discover the problem of the differing MAC addresses.

    One other thing: I made the n00b error of trying to install hyperwrt over a wireless connection, and "bricked" my router in the process, but I successfully unbricked it using the ever-popular "short pins 15-16 on the Flash chip" technique (thus voiding my warranty). Has anyone ever reported this sort of problem as a side-effect of that?

    I've already tried reinstalling the latest Linksys firmware as well as taking the last-ditch desperation measure of repeating the Flash-chip-short trick. Neither of them changed the MAC addresses.
  4. Guyfromhe

    Guyfromhe Network Guru Member

    ok then try this...
    telnet in and type:

    ifconfig eth1 down
    ifconfig eth1 hw ether xx:xx:xx:xx:xx:B4
    ifconfig eth1 up

    (eth1 should be the wireless interface this may vary if you have a v1.0 otherwise this should be accurate)

    you can ifconfig eth1 to make sure it has the b5 mac, if you do that it will use the b4 mac and you should be good to go...
    you will just need to set it to do this at bootup in the startup script section...
  5. howardp6

    howardp6 Network Guru Member

    Actually the WRT54G has three IP Addresses. the B5 one is indeed the wireless one. There is an address for the WAN port, one for the LAN ports and the highest or the Wireless
  6. phow4rd

    phow4rd Network Guru Member

    I'm assuming this is a mis-statement, and that you meant "MAC" where you wrote "IP"?

    OK, you're a "Networkin' Nut" and I'm just a "Newbie", so walk me through this slowly. You're saying that:

    1. The MAC address printed on the bottom of the unit is the WAN port address. (...:B3)

    2. The MAC address indicated on the "Status" page of the firmware configuration utility is the LAN ports' address. (...:B4)


    3. The wireless MAC address being correctly broadcast as "...:B5"??

    Is that right?

    And (no offense intended, howardp6), can anyone else confirm this?

    If so, I guess it's a case of "Good News/Bad News." The Good News is my router ain't borked. The bad news is that I have to go back to square one to figure out why my Airport Express isn't properly bridging to my WRT54G.

    P.S.: What kind of damn fool company makes a device with three MAC addresses, only prints one of them on the unit (but doesn't tell you which one), lists a different one in the software, and leaves you to guess at the third?!

    P.P.S: I haven't tried the telnet trick yet. Should I?
  7. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Same idea but with a twist. Telnet into the router and run:
    nvram set et0macaddr = xx:xx:xx:xx:xx:B3
    nvram commit

    This will survive a reboot and should give you:

    etho0/LAN: xx:xx:xx:xx:xx:B3
    vlan1/WAN: xx:xx:xx:xx:xx:B4
    eth1/WLAN: xx:xx:xx:xx:xx:B5

    It sounds like you have a MAC issue that seems to be stuck somewhere in NVRAM variable. The firmware (at least sveasoft) stores the MAC addresses like you said starting with et0macaddr. Perhaps starting from basics (factory default) would be best to clear everything then continue. Yes I am sure you tried that but don't forget you should always reset to defaults before moving from one firmware to another that way nothing is stuck in nvram. I have experienced this myself where I went from sveasoft to Linksys and it retained vars that I didn't expect to see when I went back to sveasoft.
  8. howardp6

    howardp6 Network Guru Member

    My MAC Address on the bottom of my WRT54G is XX:XX:XX:A6:98 (LAN) , the RF MAC Address is XX:XX:XX.A6:9A, the MAC Address on my status webpage is XX:XX:XX:A6:99 (WAN). There are hidden webpages that detail the information. Where is the IP address of your router, in your browser enter it will give you the MAC Addresses and other information. Sorry about the IP Address typo, should have been MAC Address. Use the B5 address. My WRT54GX has three MAC addresses also, but all are shown on the status webpage.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice