WRT54G can ping B to A but not A to B

Discussion in 'Cisco/Linksys Wireless Routers' started by Grindstone, Sep 1, 2006.

  1. Grindstone

    Grindstone LI Guru Member

    WRT54G firmware v1.00.7 has one PC (hardwired) that can be pinged from itself or any of the other PCs or laptops connected to the router by wire or wireless. None of the other PCs or laptops can be pinged from themselves or from any of the other PCs. All machines can browse the internet with no difficulties whatever.

    I'll call the pingable PC "A" and any of the others "B".

    All of the machines have interacted successfully on the RT31P2 router I use for Vonage. I have tried

    Modem -> WRT54G -> RT31P2 -> PCs
    Modem -> RT31P2 -> WRT54G -> PCs
    Modem -> WRT54G -> PCs

    All of these configurations show the same behavior. A-> A and B->A pings work, B->B and A->B pings timeout.

    A and B are running XP pro. Same behavior is observed for a laptop running Windows 2000, either hard-wired or wireless.

    Running the MS Network Diagnostics tool with everything in its most verbose mode shows no failures on A On B, the only failures are self-pings to

    route PRINT on both machines are identical, except for the network controller and the IP address (101 versus 103).

    Going to the Add Hardware control and selecting the network controller says they are both working properly.

    Pinging on both works to (local host), (A), (default gateway). pinging (B) fails on either A or B, as previously mentioned.

    From the router, the routing table entry list at one point had mappings for to WAN to LAN & Wireless to WAN

    Blocked WAN Requests included Block Anonymous Internet Requests, Filter Multicast, and Filter IDENT(port 113). It looked like the first might be a problem (can prevent pings), so I turned it off, but seeing no change, I went back to the original setting.

    I enabled router logging and did a ping from A to B, but nothing appeared in either the incoming or outgoing log. Browsing a web page showed that logging was in fact enabled.

    The router's DHCP Active IP Table showed the IP address for A, but not B.

    Any advice on how to proceed will be appreciated.

  2. HennieM

    HennieM Network Guru Member

    1) Your firewalls on the PCs might be enabled and set to block pings. Advise to turn off firewalls completely on all PCs until you resolve. There-after, maybe just disable the ICMP (ping) blocking.

    2) May be the same on the router(s), but I doubt that.

    3) Make sure the PCs are not using their "Alternate IP address", and that they in fact get an IP address from your DHCP server. I also doubt this is a problem, but just be sure.
  3. Grindstone

    Grindstone LI Guru Member

    Ping problem solved

    I turned my firewall off with no change in behavior, then back on. I assumed, incorrectly that I'd ruled out the firewall as the problem.

    It turns out, I had two firewalls enabled, Windows and Norton. I had only been aware of the Windows firewall. When I woke up to having two of them, I disabled the Norton firewall and all was well.

    Thanks, HennieM.

    As my father was fond of saying: There are none so blind as those who will not see. Which is apparently not biblical, though this is: Matthew 13:13 Therefore I speak to them in parables: because they seeing see not; and hearing they hear not, neither do they understand.

    Sounds like debugging, doesn't it?

  4. HennieM

    HennieM Network Guru Member

    Sure does sound debuggy Thanks for feedback.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice