WRT54G can't FTP to my ISP

Discussion in 'Networking Issues' started by Philip76, Jun 25, 2007.

  1. Philip76

    Philip76 LI Guru Member

    Hi all,

    I've looked through previous threads but haven't seen an answer to my specific question so here goes:

    I am trying to log into my ISP's web server via FTP to transfer my web site onto it. This procedure works perfectly if I connect my computer directly to my ADSL modem, but won't work via my WRT54G. I have tried to fix this after discussing it over the Linksys Live Chat support system (which is a very good system by the way) but the fix hasn't worked. I'll go back to the support people if I can't work it out soon, but I thought I'd ask you folks first.

    The instructions from Linksys were to open the ports required for FTP by going to the Port Triggering screen and listing them there. I also tried the Port Forwarding screen but I thought that only applied if I was trying to run an FTP server (hence the router's need for an IP address in the port forwarding screen). But I did it anyway and it still didn't work.

    The computer connects to this router by cable via a Netgear switch. We're not trying to do it wirelessly. Both the cable and wireless connections of the router work perfectly for web browsing and email, it's just the FTP that isn't working (and I haven't tried FTP over wireless so I don't know if that works).

    When I try to FTP to the server at the ISP, using Windows Explorer for example, it sits there for over 30 seconds and then says it can't connect because the connection was reset by the server. It never brings up the username/password box. On a Mac, using Cyberduck, it tries to log on for around a minute and then says it timed out.

    When I connect straight to the modem, leaving the WRT54G out of the picture, it works perfectly. The username/password box appears instantly and it logs in and can transfer files without problems.

    Are there settings I'm missing in this WRT54G? Am I right in thinking the Port Forwarding has nothing to do with this because I'm a client and not a server?

    What can I do? I don't use FTP very often - maybe once a month to update our family web site - and I can do it by plugging straight into the modem (and thus disconnecting the rest of the network from the internet for a few minutes), but I'd still like to get it working. I'd like to be reassured that this otherwise stylish and competent wireless router is able to do its job properly!
  2. Toxic

    Toxic Administrator Staff Member

    what mtu setting are you using?
  3. Philip76

    Philip76 LI Guru Member

    Yeah I forgot to mention that. We have calculated the right MTU size by pinging with various packet sizes until we worked out the maximum size, then setting the router to that. I assume the modem doesn't add more bytes to each packet. Perhaps I should reduce the router's MTU by another 28 to allow for the modem adding more bytes, in case it does. I'll try that tonight when I get home.
  4. frenchy2k1

    frenchy2k1 LI Guru Member

  5. Philip76

    Philip76 LI Guru Member

    I'm using Cyberduck on the Mac but I haven't yet tried a dedicated FTP program on the Windows machine. I will try PORT mode tonight. Didn't get time last night.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice