WRT54G Connection Problems

Discussion in 'Networking Issues' started by klemmy, Apr 5, 2006.

  1. klemmy

    klemmy LI Guru Member

    For the past few days I've been trying to connect my wrt54g version 5 wireless router to my computer. I know how to hook it up correctly but I can't get a connection. I can connect to the computer using my modem but once I connect it to the router I no longer get a connection. When the router is hooked up I get little or no connectivity and I cannot access any sites or do anything else online.

    I've tried to access the router by typing the IP address but I could not access it because it comes up with "internet explorer could not open the search page."

    My ISP is Roadrunner and my modem is a "Touchstone Telephony Modem" and I believe it is made by Arris. I just recently got this new modem because I got digital phone service. My router worked fine with my other modem but will not connect with this one. I've tried resetting the router and many of the troubleshooting techniques on the Linksys site. I have no clue what to try now because it seems like everything I try doesn't work and I am completely lost.

    If anyone knows what I could do to get this to work the help would be greatly appreciated!
  2. jgutz20

    jgutz20 Network Guru Member

    is your router giving you an IP address? try setting your IP address manually and then make sure you can PING before you try to access the web page.
  3. bluebox

    bluebox Network Guru Member

    Also check that you new hardware isn't set to the same subnet as your router - or your router won't be able to route to it.

    In other words, if your linksys box is 192.168.1.x your new touchstone modem can not be on 192.168.1.x (unless you plug it into a LAN port on the router, which will elimnate routing functions and the firewall between your LAN and the new modem.)
  4. klemmy

    klemmy LI Guru Member

    My router does give me an IP address but it has limited or no connectivity. Also, it does not give the the IP address. Instead it gives me the IP address I can ping that IP address but I can't ping any other IPs or websites.

    If I set the IP address manually what should I set it to?

    Also, I don't think that my router and modem are set to the same subnet because all of the numbers are completely different. The modem is not set to 192.168.1.x or anything close to it.

    Also, if I try to type in the address into internet explorer it still comes up with the error "internet explorer could not open the search page"
  5. jray

    jray LI Guru Member

    I have the exact same problem.

    Is your situation like this one?

    -You're a relative newbie to all this networking stuff.
    -You want to use a WRT54G as a repeater.
    -You browse around and discover that the WRT54G has an open source community, and the prevailing wisdom says that the DD-WRT package is the best way to turn the WRT54G into a repeater.
    -You upload the DD-WRT firmware to the router
    -You connect to it briefly, but stops responding
    -So you unplug it for awhile, and press the reset button

    (Here is where our situtations are identical)

    - The router shows up as linksys, channel 6 in a wireless scan. The default settings, for all appearances.
    - Connect to it.
    -Connecting takes a long while--much longer than usual.
    -Finally it connects. The IP settles on 169.254.x.x. (I'm not sure, but I think the x's change between connection attempts)
    -The default subnet mask is, not the x.x.255.0 as expected
    -The configuration page is unreachable. Additional resets don't change anything.

    Our situations sound eerily similar. If one of us can find an answer, perhaps both of us can.

    Good luck!
  6. jray

    jray LI Guru Member

    After searching around for some ideas, I am now able to access the router.

    It turns out that all I needed to do was hold in the reset button for about a minute. The forum topic said 30 seconds, but I went longer. This reset the modem to the default DD-WRT configuration, and it is accessible again. You might try holding in your reset button for longer than you might otherwise.

    Now all I need to do is figure out how to make this thing into a repeater. There is a vast amount of info on this website, and searches for a solution aren't unearthing the magic bullet--yet.
  7. klemmy

    klemmy LI Guru Member

    Yeah our situations do sound similar. I'll try holding in the reset button for longer. I have no clue what a repeater even is so I can't really help you there. Hopefully the reset thing will work because this thing is really starting to get on my nerves. It seems that I've tried everything I could possibly do but nothing works.
  8. bluebox

    bluebox Network Guru Member

    That IP address that you have, it's one Windows assigned you because it couldn't find anything handing out IP addresses. Perhaps your DDWRT router wasn't configured for DHCP? I never use DDWRT, so I couldn't tell you where to go for that.

    Good luck!
  9. klemmy

    klemmy LI Guru Member

    Internet explorer could not open the search page

    Alright I'm making some progress here. I held the reset button for about 60 seconds and it definitely changed something. Now when I plug in the router it gives me a correct IP address of instead of that 169 IP address.

    However I still can't access the router's configuration page. Typing in should bring me to that page but when I type that in an error pops up saying "internet explorer could not open the search page". If anyone knows how to get past this error the help would be greatly appreciated
  10. imp_squared

    imp_squared LI Guru Member

    Re: Internet explorer could not open the search page

    still getting the same problem??
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice