WRT54G Dead yet Alive - Please help if you can!

Discussion in 'Cisco/Linksys Wireless Routers' started by Ixsys, Jan 13, 2005.

  1. Ixsys

    Ixsys Network Guru Member

    Hello all,

    I've been a long time reader of these forums and just regged an account since tonight everything went sour for me. Perhaps one of the kind members here can shed some light on the issue and possibly help me fix it?

    What happened:

    I had a WRT54G with HyperWRT 2.0b3, that was running fine. In my infinite wisdom I decided to try to upgrade it to 2.0b4 (Beta4). I used TFTP for this proceedure, and I must admit it went rather faster than I was expecting. Upon its auto reboot the power light flickered (as it had done so many times before after being unplugged/re-flashed, however did not stop flashing (it usually stopped after a min or two). Since then I've not been able to access the config @ nor have I been able to successfully flash it.

    That said. I read the re-animation guide where I was told to short pins 15&16. Which was fine, I set everything up got the pc pinging constantly made sure there was no reply from the router, then followed the directions. It came alive! So I flashed it - everything was peachy. Got into the config and everything. So I unplugged the router and put its casing back on. Plugged it in only to find that the blinking power light had returned. I did my usual waiting period to no avail. I tried resetting the device again to no avail.

    All that said, when I plug the router in and set a static IP on my pc the router responds to ping which leads me to think its not quite dead. That said, the response time fluctuates between 1ms and several hundered (3-400ms) while pinging the router.

    So at the point the router will respond to ping if the static IP is set.
    I cannot access the config, and every flash I've tried so far says its worked but never does.

    Can anyone help me? Please?!

    Thank you for your help!

  2. lonewolf

    lonewolf Network Guru Member

    Sounds like the NVRAM vars are toast. If it's a v2.0 or later, unplug it and then plug it back in while holding the reset button. Release 5-10 sec after you plug it in.

    If it's an earlier version, you will need to log in and run 'erase nvram; reboot' (you said it comes up when you first flash it, right?)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice