WRT54G debricking process

Discussion in 'HyperWRT Firmware' started by Blast, Jan 1, 2006.

  1. Blast

    Blast Network Guru Member

    Any help would be appreciated. Here is my issue

    Trying to flash with Alchemy V1.0

    FIrst, I set my IP to
    My subnet
    Default G:
    Preferred DNS

    OK, when I try to TFTP the .bin to the router, It waits a few seconds and then comes back with"Connect request failed"

    Not sure why

    When I run the lynksis utility, it tells me I am unable to get responses from the server

    Again, not sure why this is occuring

    I can ping - I'm assuming that is the right place to ping because I set it to a static IP

    I also can not run an arp -a it tells me "No ARP Entries found.

    Am I out of luck or am I doing something wrong
  2. crawdaddy

    crawdaddy Network Guru Member

    is your router running with the IP of or is your computer running with that IP. you should be TFTPing to whateer your router is, usually
  3. Blast

    Blast Network Guru Member

    OK, when I tried the TFTP process with I get a
    "timeout occured"
    "connect request failed"

    I also can not ping
    My power light is flashing

    Thanks for the response, any other ideas?
  4. MarkInDavis

    MarkInDavis Network Guru Member

    You should have brief access after power cycling the WRT54G. To test type "ping -t" to continuously ping it. While that is running, power cycle the router. Shortly after the power cycle, it should briefly respond to pings, then you'll get "request timed out" again. You must start your tftp process during this small time window. Power cycle again and give it a try.
  5. Blast

    Blast Network Guru Member

    Great, thanks a bunch... I was able to unbrick it but now when I try to load the firmware I get the "invalid pw"

    I'm trying to find a TFTP program that will enable me to enter the password but I'm not sure where to find the right one.

    Can someone point me in the right direction?

  6. MarkInDavis

    MarkInDavis Network Guru Member


    The above from linksys lets you enter a password. Again, if you load firmware in the short window after a power cycle you won't need a password. Or you can just go through the web interface of whatever firmware you have loaded.
  7. Blast

    Blast Network Guru Member

    OK, I'm using the tftp program you supplied and when I hit the upgrade button I'm receiving

    "wrong Code Pattern"

    any idea what this means?
  8. MarkInDavis

    MarkInDavis Network Guru Member

    What hardware version of WRT54G do you have, and what firmware are you trying to load?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice