WRT54G DHCP server problems

Discussion in 'Cisco/Linksys Wireless Routers' started by asthion, Nov 23, 2007.

  1. asthion

    asthion LI Guru Member

    Newbie to the site... just a heads up before I start my tale of woe.

    Had a WRT54g (ver 6 with latest firmware) that was previously working perfectly using a 2wire broadband modem in bridge mode using SBCyahoo DSL. I have a Dell XPS M170 with Intel 2915 PCI WiFi card connecting to the router. I am using a linksys Range Extender. The extender has been in place for months with not a problem (don't ask about the install problems). Then I made the mistake of installing Vista. I returned to XP and started having router problems.

    The router is less than 10 feet away but has 2 interposing walls. Previously, the signal was always excellent. Now the signal starts at excellent and steadily degrades to poor prior to disconnecting from the router. When the laptop tries to reconnect I get a DHCP server error and the laptop uses APIPA to generate a 169.254.x.x address. This happens every 3-15 minutes and is completely random from what I can gather. Even rebooting the laptop or unplugging the modem won't always work.

    I have tried everything. Reset the router to factory default and soft reset. Updated the firmware. Replaced the original with a new WRT54G. Even got a WRT300N. Always the same problem.

    I had the line checked by SBC. It's good. I updated the drivers on the laptop. No help. Uninstalled and re-installed the WiFi drivers with no help. Reset the TCP/IP stack, nothing. Used ipconfig with release and renew operators. Again nothing. Disabled Zonealarm firewall, nothing. Ran virus scans, clean system. smitrem was run, again clean system. Spyware checks, nothing. Tried using both intel's framework software and WZC to configure the connection, always the same problem. Used winsock repair programs, again no help.

    I am completely at a loss.

    Any help would be appreciated.
  2. asthion

    asthion LI Guru Member

    Sorry about the double post.
    1 addition. I use WPA with TKIP for security and the SSID is broadcast.
  3. ifican

    ifican Network Guru Member

    Interesting indeed,

    You say everything was working before the upgrade then it stop immediately after?

    When you downgraded to xp did you do a complete formate or a quick format?

    Changing OS could created weird behavior but cannot break your router physically. Vista rebuilt the tcp/ip stack microsoft uses so it has cause grief with certain things, but i run vista and personally have not had a single issue with connectivity. Well after the fun i had getting all the necessary drivers needed to make it all work.
  4. mstombs

    mstombs Network Guru Member

    Try fully uninstalling zonealarm or any Symantec AV/Firewall. Some of these have a habit of hanging around when they are 'disabled'.
  5. asthion

    asthion LI Guru Member

    Sorry about the delay in replying.

    Tried unstalling AV/Firewall software and reinstalled the OS as well. Again nothing.

    I finally got desperate and tried messing with the router settings. After changing the password protection from WPA with TKIP to WPA2 with TKIP & AES, everything worked perfectly.

    I don't get it, but I think the WiFi gods have been appeased.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice