WRT54G Error (IP Address and Gateway is not on same subnet)

Discussion in 'Cisco/Linksys Wireless Routers' started by ywkhiang, Feb 12, 2006.

  1. ywkhiang

    ywkhiang Network Guru Member


    I bought a WRT54G v5 recently and cannot connect to the internet through the WRT54G router. I've no problems when the RJ45 is connected directly to my laptop.

    When I access the router page (, I discovered that the Gateway is set to "". When I tried to configure this to the one given by my ISP, I keep getting an error, "IP Address and Gateway is not on same subnet". I've contacted my ISP and they have informed me that their network is set up using different gateways and due to certain restrictions. However, a WAP like Cisco Aironet 1200 will work.

    However, I've already invested in the WRT54G. Can I still get it to work on some workaround solution? Is there any firmware upgrade I can do to support different gateways?

    Pardon me as I am a novice where all these is concern.


  2. VortexSwirling

    VortexSwirling Network Guru Member

    If you possibly can, return the V5 for a WRT54GL or WRT54GS. They are a little bit more money but it is worth it. V5 is running VxWorx and not Linux, so you can't try any of the 3rd party firmwares. A 3rd party firmware would probably solve your problem right away.
  3. dvaskelis

    dvaskelis Network Guru Member

    It sounds like you're confusing the configuration of the WAN (Internet) gateway with your LAN (local network) gateway,which is typically the router itself and in most configurations isn't something you need to set.

    On the "Setup" page, under the "Basic Setup" tab, what do you have for "Internet Connection Type"?

    Most cable modems will use "Automatic Configuration - DHCP", most DSL modems will use PPPoE. In either case, the WAN gateway is then typically populated automatically by the ISP.
  4. ywkhiang

    ywkhiang Network Guru Member

    Hi dvaskelis,

    The Internet connection type is "Static IP". I have been advised by my ISP to change it to a Cisco Aironet 1200.

    However, I'm still puzzled why the WRT54G can't work whle some other brands can.


  5. jgutz20

    jgutz20 Network Guru Member

    if you have the static addresses set correctly in the router i dont see how you could have this problem, on the setup page make sure you arent setting the LAN IP address to this same address like dvaskelis said.
    change the "automatic configuration - DHCP" to Static from the drop down and enter the numbers in here. Under the Network Setup, this IP address will be the DNS and gateway for your computers you connect to this device, leave it at or similar. After you do this you should be able to goto the status tab and see the connection information and then able to get online.
  6. ywkhiang

    ywkhiang Network Guru Member

    Hi jgutz20 and all,

    Regards to setting "Automatic Configuration - DHCP, how should I set my "Starting IP Address"?

    My ISP has given my static IP as:

    IP: to (only 2 IP addresses)
    Subnet Mask:

    You can try keying in the above into the WRT54G v5 with the latest firmware to see the error that I am getting when I set my Internet Connection type to "Static IP". The firmware rejects the above IP Addresses with the described error.

    I hope when I set it to "Automatic Configuration - DCHP" and it will help solve the problem.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice