WRT54G - Internet but no networking?

Discussion in 'Networking Issues' started by Ribby, Feb 11, 2005.

  1. Ribby

    Ribby Network Guru Member

    Hi there,

    I just got myself a WRT54G and love it. However I am having a problem...

    I've been reading on here and have seen a couple of others have similar issues where internet connections can work yet computers cannot see each other on the network.

    I have a Nokia M1122 ADSL Router giving my net connection to the WRT54G. The M1122 is running DHCP, the WRT54G has DHCP Server disabled.

    Each machine is running XP SP2, both without any firewalls of any kind (Linksys also disabled). No WEP running, just a MAC filter only accepting my laptop. Same workgroup, both have netbios active under WINS in TCP/IP prefs.

    Each PC can ping the other - so they see each other, however when I attempt to access files over the network I get the "is not accessible. you might not have permission to access this network resource" message.

    I've attempted (and am currently still using) the "Satori-4.0 v2.07.1.7sv" firmware, and have tried disabling loopbacks. When I did this all internet died completely on the laptop.

    I'm at my wits end... what can I do?
  2. Esquire

    Esquire Mesquire Staff Member Member

    I presume you have setup folders for network sharing?

    Are you able to access them by UNC (\\computername\shared folder name\)?
  3. Ribby

    Ribby Network Guru Member

    Hi :eek:

    Yes both the PC and laptop have shared folders that have been used daily for the past 6 months.

    Login and password on each would be the same (identical account info) however they both are openly shared as it is a closed network.

    I've just found out my imac in the other part of the house has no internet either since the introduction for the Linksys :(
  4. Ribby

    Ribby Network Guru Member


    Progress, I've disabled DHCP on the m1122 and am instead letting the Linksys take care of it.

    Net works for all machines, can see all machines, filesharing still does not work though! :cry:
  5. Esquire

    Esquire Mesquire Staff Member Member

    You didn't say whether or not you could access shared folders by UNC.
  6. Ribby

    Ribby Network Guru Member

    Hi Esquire,

    Sorry UNC didn't work - it gives a permissions error :cry:
  7. Esquire

    Esquire Mesquire Staff Member Member

    Same error as before? Home Edition or Professional? Check your access privilege.

    On Professional, disable Simple File Sharing -> Control Panel > Folder Options > View.
    Right click a shared folder and select Properties, then click the Security tab.
    Make sure you have an user entry called Everyone and has been given enough privilege for your other computers to access it (thus no need to having Windows logon the same user solely for this purpose).

    On Home Edition, by default you need boot to Safe Mode to gain access to the Security tab.
  8. Esquire

    Esquire Mesquire Staff Member Member

    Also, check if Computer Browser conflict is the culprit.

    Control Panel > Administrative Tools > Services.
    Disable Computer Browser on all BUT your main computer.
    Reboot all computers (main computer first) and see if that fixes the problem.
  9. Ribby

    Ribby Network Guru Member

    Ok have tried all of these (using xp pro).

    I've added another laptop to the network and it also has the same issue.

    Search me, I think I'll just have to use ethernet with them at home for filesharing..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice