wrt54g problem after changing cpu frequency

Discussion in 'Tomato Firmware' started by pluv, Aug 3, 2011.

  1. pluv

    pluv Networkin' Nut Member

    hello guys,

    some weeks ago switched from dd-wrt to tomato toastman mod.

    worked very well, until today i changed my cpu frequency to 266, saved, rebooted the router and.. it doesnt start up.

    the power led blinks all the time (DMZ doesnt blink at all), the internet led blinks too, but not as frequent, but always together with the led where my pc is connected to.

    well, the router still connects to the internet, but i cant access the webinterface, wlan doesnt work, but i can still go online, when i directly connect my pc to it.

    i tried tftp once or twice but always got a timeout (well maybe i just did it wrong).

    i hope someone can help me, i dont know what i can do about it, and i dont want to open my router up (i dont trust my hardware modifying skills that much)

    (i posted the same thread on another forum but this one seems way better)

    edit: after observing my router for a while, the internet led blinks only like every 15-20 seconds
  2. Beast

    Beast Network Guru Member

    Have you tried a hard reset? Remove power from router hold in the reset switch, while holding the reset in plug power cord back in and continue to hold the reset button for at least 30 seconds more. This should reset the nvram to factory defaults. If this does not work there are some debricking instructions around.
  3. pluv

    pluv Networkin' Nut Member

    that didnt do anything. still the same problem.
    can you link me to those instructions?
    all I found was telnet/tftp and jtag.
    telnet/tftp didn't work and the jtag version would cost me more than buying another wrt54g from ebay.
  4. Mercjoe

    Mercjoe Network Guru Member

    Performing a hard reset will not clear the value for the CPU speed that you set. You have to set up a JTAG and reprogram it to reset it properly.

    You probably are overheating the CPU on the router due to the overclock. I did that once myself.....

    WARNING: Potentially Dangerous advice follows.

    Put it in a freezer.. when it is good and cold, pull it out, boot it.. and get in the webinterface and back the clock back down. You have a VERY VERY short window to do this in.

    WARNING: Freezing will cause condensation. Condensation and electricity can be a BAD BAD thing, Proceed at your own risk!

    If you want something safer.. put heatsinks on the CPU and use active cooling (i.e. a fan) and see if that helps keep it running long enough to reset it.. This will require you to open the router to place the heatsink on the CPU itself.
  5. GhaladReam

    GhaladReam Network Guru Member

    The WRT54G is not able to be clocked that high... Especially if it's an early one such as a v1 or v1.1, those only had a 125MHz cpu if I remember correctly. 266Mhz would absolutely fry it in that case.
  6. pluv

    pluv Networkin' Nut Member

    oh, alright, i didnt know that, it was on "undefined" and in the frequency settings "266" was right in the middle so i thought it was the average speed.. damn...
    I will try the thing with the freezer now, seems like i have no other choice.

    putting it in the freezer didnt work. it started up with the blinking and i couldnt connect to it.
  7. Mercjoe

    Mercjoe Network Guru Member

    JTAG may be the only hope of recovery....

    I would just upgrade to a newer router and enjoy the benefits. I went from a WRT54G v2.2 to a WNR3500L and never looked back.
  8. Beast

    Beast Network Guru Member

    If you can ping it, you should be able to debrick it. See this page http://en.wikipedia.org/wiki/Linksys_WRT54G_series
    for your model's CPU speed. Also there are some pin shorting methods, but you need to know the model number of the router. Different pins
    for different models. (I have used this method on one of my old WRT54G v3.1) And it worked fine. But use at your own risk!!!
  9. ntest7

    ntest7 Network Guru Member

    I would suggest *NOT* trying the pin shorting trick. The risk is very great and very real, and even if you do it right it probably won't fix the problem anyway.

    If you can ping it, you should be able to flash it with TFTP. You may have to try 20 times to get the timing right. Be persistent.
  10. sigmmma

    sigmmma Networkin' Nut Member

    If you cant ping it, use the pin method, i use it so many times... in fact if you do it right nothing bad happend, just be careful selecting the correct pin in the intel module flash and you will get your device back again. And actually if you do make a 100ms ping you should know that the correct timing is 4-5 times after the first you receive, after that you wont get access to the router and the firmware file wont up. Note: Use the original firmware file from linksys to upload the fresh tftp first attempt. (Btw i own a WRT54G v2.2)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice