WRT54G - retrieve PPPoE password

Discussion in 'Cisco/Linksys Wireless Routers' started by q20, Dec 6, 2004.

  1. q20

    q20 Network Guru Member

    hi there

    was just wondering if anyone knows a way for me to retrieve my pppoe password from my router... i'm using the Wifi-box.net Release Version: firmware and thought it may be possible to get the information i need using telnet. or something like that. sounds easy, but probably isn't. no idea how to use telnet, you see.

    in case you're wondering, we've lost our letter from our ISP with the username and password and i can't be ar$ed calling to request the info. besides, it'll take too long. so, if one of you fine specimens could furnish me with instructions as to how to do this, i'd be most appreciative.

  2. littlewhoo

    littlewhoo Network Guru Member

  3. q20

    q20 Network Guru Member

    thanks so much for the quick reply... um, next problem:

    tried logging in to the router with a telnet app, but i keep getting a "login incorrect" error. i'm using the login that use when i need to make changes to the router. what other username/password combination could there be? i would think none. i've tried admin/password and Admin/password, thinking that it could be an issue with case, but obviously not... any ideas?
  4. q20

    q20 Network Guru Member

    don't worry mate... did a little searching in this forum and found the solution. i have to login as "root", not "admin". thanks for your help pal.
  5. q20

    q20 Network Guru Member

    right... problem again

    did as you suggested after logging in (successfully) to the terminal. typed nvram get pppoe_passwd and nothing seems to happen. back to the prompt...

    tried adding the "show" switch afterwards and it seems all information pertaining to the router was printed to the screen. only thing is, i can't find pppoe_passwd in the printout. if i type nvram get pppoe_username it works. no problem there. is the variable for the password maybe something other than pppoe_passwd? tried pppoe_password, but that didn't work either...

    i'm now using the satori 4.0g fw, btw
  6. littlewhoo

    littlewhoo Network Guru Member

    On Satori the pppoe_passwd nvram parameter should definitely be present. I'm using Satori 4 on one of my routers and just did verify this.

    Please try searching in your "nvram show" output for strings like "pppoe" or "pass". Maybe this will help you finding the correct parameter.

    You can do this with
    "nvram show|grep pass"
    "nvram show|grep pppoe"

    Or perhaps your DSL line is not using PPPOE at all, but PPTP like the DSL lines in Austria. So searching with
    "nvram show|grep pptp"
    might also help.
  7. q20

    q20 Network Guru Member


    just did an nvram show, searched through the whole thing for any pppoe strings. nothing useful.


    tried nvram show|grep pass and am pleased to say that there i've found the password! it's "wan_pppoe_passwd". the odd thing is that that variable does not appear in anywhere in the printout resulting from "nvram show".

    thanks so much for your help. it's most, most appreciated. now i can finally install our new WRV54G VPN router. prepare for more trouble.... :p
    phlibby likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice