WRT54g - Strange problems...

Discussion in 'Cisco/Linksys Wireless Routers' started by slack---line, Dec 4, 2006.

  1. slack---line

    slack---line LI Guru Member


    I have a WRT54g v1.1 that until the other day was working fine. Turned the laptop off (which was connected via wireless) in the evening and the next morning it would not connect to the router (despite the power and WLAN lights being on).

    I've done some playing around, first I tried resetting the router, and could then connect using cable to change the setup via the web-page at, but half-way through I started getting "Connection refused" messages and couldn't see any of the config pages. Power-cycling didn't resolve this. I decided to try upgrading the firmware so downloaded the latest and reset the router which allowed me to access the config page and I upgraded succesfully, but again after a while I started getting "Connection refused" messages and couldn't do anything.

    Its impossible to get an IP address over wireless, dhcpcd (I run GNU/Linux on my comps) just times out no matter how long I set the time to, even after four-five minutes.

    I don't know masses about this router (despite having been using one for a couple of years), but I'm starting to suspect that someone might have hacked (and not in the tinkering sense, but the malicious sense) into it and done something nefarious to the setup (I can see two or three other SSID's that are being broadcast in the area). I've noticed that the WLAN light does flash fairly regularly despite the fact that I can't connect to it, which makes me think that someone is connected to it via wireless.

    If anyone has any suggestions as to how to check whether the box has been compromised I'd be very grateful,


  2. slack---line

    slack---line LI Guru Member

    Okay, now back at home and tinkering with this again.

    I've tried another hard-reset, making sure the reset button was held down for a good 40 seconds, and power-cycling as well, but the same problem. Logged into the router and then tried to start changing the config, and one of the things I've always done in the past is restrict wireless access to a specific list of MAC address' for the hardware that I have (two laptops). Upon trying to save the the list, nothing happens, it just sits there and times out, and all attempts to connect to are refused, and I then can not access any of the setup pages. I should mention that at this stage the connection is via cable and not wireless.

    Would this be evidence that the security of the box has been compromised? Should the connection be refused half-way through changing the settings?

    Thanks in advance
  3. HennieM

    HennieM Network Guru Member

    Couple things to try maybe:

    Make sure you don't have another DHCP server running on your net.
    Set your wired connection to a static IP, then try the config. Turn off UPnP on the router (I dunno exactly what/how UPnP works, but eliminate anything that COULD allow external enterference).
    Make sure there isn't a proxy server somewhere that you are being redirected to (maybe by your ISP or the settings for the ISP on the router).
    Try different wireless channels.
  4. slack---line

    slack---line LI Guru Member

    Thanks for the tips Hennie :thumbup: , will give that a got this evening when I get home.

    I'm considering just slacking it off and installing something like OpenWRT instead, but will see if I can get it working first.
  5. slack---line

    slack---line LI Guru Member

    Okay it seems that all of this is down to a buggy release of dhcpcd-3.0.0 which was installed on my system. Upgraded to dhcpcd-3.0.2 and everythings back working.

    For those interested this problem was on a gentoo ~x86 system and was all on the client side, and not a problem with the router. Still might look into OpenWRT though (when I have a spare router to brick ;-)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice