WRT54G stuck in access point mode, power light flashing, no tftp or http interface

Discussion in 'Cisco/Linksys Wireless Routers' started by popojack, Oct 8, 2008.

  1. popojack

    popojack Network Guru Member

    I have a WRT54G v2 with Linksys firmware version 4.21.1.

    My power light is flashing continuously. I have attempted a hard reset by holding the reset button down for 30 seconds, unplugging power, and releasing. I have also done the same sequence and left the reset button depressed while powering back up. The reset button seems to be having no effect; the Internet and Ethernet port lights do not ever appear as if they are cycling though a reset.

    I seem to be stuck in access point mode without the WRT54G's DHCP server. I have an RT31P2 phone router upstream. A PC plugged into one of the WRT54G's Ethernet ports can access the Internet, but is receiving its IP from the upstream phone router. When looking at the phone router's DHCP client's, I see my PC that is plugged into the WRT54G, but not the WRT54G itself.

    I cannot access the router via the http interface at I have tried tftping into the router with a machine with static IP set to, but no luck. I tried shorting pins 15 and 16 on the flash chip while powering up, still no luck getting a live ping from I have also tried the obvious of cycling power on all hardware to resolve any DHCP conflicts.

    Any other ideas or anyone had a similar problem to this before? Thanks
  2. popojack

    popojack Network Guru Member

    Next step - JTAG cable

    Have ordered and will be trying a JTAG cable on this unit - will post results when I have them.
  3. popojack

    popojack Network Guru Member

    One step further, next obstacle...

    Just got the JTAG cable, and got it talking.

    Used HairyDairyMaid's wrt54g utility. Backed up cfe, kernel, nvram, and wholeflash. Erased wholeflash. Used skynet utility to create a cfe.bin with my MAC address. Used HDM to upload cfe.bin, successful, and can ping the router at

    Went from blinking power light and no DMZ light to blinking power and slow blinking DMZ. I am assuming this means I made it to failsafe mode. I am able to tftp images as soon a I power the unit on. After tftp upload the DMZ light goes solid. I wait a couple of minutes to allow time for the flash to set up, but nothing changes,

    Power off/on and hard resets result in the same condition.

    I have tried tftp'ing openwrt and it uploads successfully, but lights stay the same and I cannot telnet in. Any ideas on things to try from here?
  4. popojack

    popojack Network Guru Member

    More info. I tried uploading CFE.BIN generated by the Skynet utility, and by the web page at http://lonewolf.hacker-nin.com/wrt/cfe/

    Both cause the DMZ light to go solid after loading, but upon power down/power up or hard reset of the router I go back to failsafe mode. At all times I can ping, and at power up I can tftp a kernel with reported success.

    I did a hex compare on the two generated CFEs and they are identical. However, when I comapre the generated CFEs to the CFE backup I made prior to erasing wholeflash, there is an interesting difference. The generated CFEs place my MAC at file offset address 00001E00, while in my original CFE the MAC is at 00001E09. ???

    When reflashing my original CFE, the DMZ goes off and stays off, even after power down/power up. I can tftp a new kernel, but upon reboot I cannot telnet (tried OpenWRT) or access the web GUI (tried both Linksys and OpenWRT).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice