WRT54G "TKIP+AES" encryption?

Discussion in 'Cisco/Linksys Wireless Routers' started by plink0025, Jan 1, 2006.

  1. plink0025

    plink0025 Network Guru Member

    i'm setting up encryption on my router, i'm want to use wpa2 because i hear it's stronger than wpa and AES as the algorithm, because its apparently stronger than TKIP, but for some reason, i cant connect from windows with AES, it only works if i use TKIP+AES. but, does TKIP+AES mean it's like double encrypting the signal using both algorithms, or does it just mean that it can use either algorithm, depending on what the client computer uses? whatever it is, it works with windows, but it breaks my wifi setup in linux and i dunno how to setup wpa_supplicant to use TKIP+AES. is there any way to make windows work with AES?
  2. DoC_DaR

    DoC_DaR Network Guru Member

    Yes, windows does support WPA AES. Now the real question. Does your wireless adapter support WPA AES?
  3. plink0025

    plink0025 Network Guru Member

    it must, since it worked with aes using linux and wpa_supplicant. its an ipw2200bg card, which seems to be pretty standard on laptops. with windows it gives me an error when i try to connect and it only has TKIP as an algorithm option when i setup a preferred network. do i need some kind of updates or something? i think i'm running sp2. what does that TKIP+AES option mean exactly though?
  4. nuropa

    nuropa Guest

    there is a WPA2 update for Windows XP, did you install that? you can download it from microsoft
  5. plink0025

    plink0025 Network Guru Member

    i just tried downloading a "wpa rollup" update package from microsoft.com and it said i already had the update. what i really what to know is.
    1. when i set the encryption to "TKIP+AES", what happens? if i then set windows to use TKIP and connect, is the signal being encrypted with AES/CCMP with some kind of TKIP front-end, or is it just using TKIP?

    2. how can i get AES support in windows. when i go to set up a network, the only encryption option i get is TKIP. if i try to get on a network using AES, windows tries to connect for about 10 minutes and gives me an error.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice