WRT54G, Trying to get two machines to share nicely

Discussion in 'Networking Issues' started by AndyMan1, Sep 1, 2006.

  1. AndyMan1

    AndyMan1 LI Guru Member

    This is yet another twist on the same problem that i've diligently searched the forums for solutions. I've tried everything suggested, nothing seems to work (permanently) so I'm now asking for help.

    The Setup:
    cable modem -> wrt54g -> wired connection to desktop
    ~~wireless to laptop
    The Culprits:

    -WinXP Pro SP2, fully updated,
    -NVIDIA nForce MCP Networking Controller
    -assigned address of
    -WinXP Home SP2, fully updated
    -Dell Wireless 1470 Dual Band (i.e. Broadcom chipset)
    -dhcp acquired address of

    The Situation:
    I'm trying to share a drive on the desktop with the laptop. I *have* accomplished this at least twice, once with the laptop wired, once wirelessly last night. Turned off the PC for the night, and now I can't get it back.

    I've run the networking setup wizard on both numerous times. I've fiddled with nearly every setting i can find.

    Internet works fine on both. No firewalls, windows or otherwise. Desktop can ping router and laptop. Laptop can ping router, cannot ping desktop.

    I used ethereal to check what was going on with that. When the desktop pings the laptop, all is well. When the laptop attempts to ping the desktop, the packet will leave the laptop, but never arrives at the desktop.

    Both on MSHOME, both uniquely named. only using TCP/IP.

    The desktop can see both machines in the workgroup, cannot access laptop (network path not found). The laptop can only see itself (has been able to see desktop before, but again network path not found). //compyname doesn't work on either, neither does //192.168.1.x

    All the settings in the router are fairly normal, from what i can tell.

    I've tried, and retried everything i can think of. I got it to work last night, but I have no idea how.

    any ideas?
  2. AndyMan1

    AndyMan1 LI Guru Member

    ****... sorry for the double post
  3. wimaxed

    wimaxed LI Guru Member

    Are you running any type of software firewall?? (ZoneAlarm, PC-Cillin, NIS)
  4. AndyMan1

    AndyMan1 LI Guru Member

    no software firewall on either machine. no ZoneAlarm nor Windows Firewall
  5. thyssen2k

    thyssen2k LI Guru Member

    actually it should be \\192.168.1.x and not //

    furthermore, i think its best, if you have the same login names and passwords on both machines. xp, no matter which version that is, doesn't like accounts without passwords that much.

    desktop - you login as admin with password admin
    as for you have an account admin on your notebook with the same password, access to the drive should succeed.

    vice versa too, if you log on your notebook with user and password user, you should need the same account on your desktop to establish a connection to the share.

    that always worked for me, if you don't have an AD / DC environment.

    so, now to the problem, why you don't see your machines in your network neighborhood...

    this usually fails if you don't have DHCP enabled on your router.

    did you try to ping the machines?

    a possibiliy to bypass DHCP is to edit your HOSTS file ( in the \windows\system32\drivers\etc directory) and adding your machines to the list.

    example: localhost NOTEBOOKMACHINENAME

    you could though, depending on your router, turn on DHCP and give your machines permanent IPs.
  6. ifican

    ifican Network Guru Member

    Wow good one indeed. To further narrow this down you state that you can only ping one way on one device. And since both machine are on the same subnet there shouldnt be any reason for the packets to cross anything other then the switching engine. Trying pinging from the router to either machine, if the ping is successfull then try both ways, if it is not successfull it would have to do with how the router is handling arp resquests and its internal arp table. All of these devices are suppose to be "transparent bridges" however there are plenty of cases that they get gummed up. Rebooting should fix it but will not tell you why it happens in the first place. Give it a try, report back and we should have a little better direction on which way to go to help resolve.
  7. AndyMan1

    AndyMan1 LI Guru Member

    Wow. I'm completely stumped by now. Let's see, replies first:

    -yup, got the slashies wrong in the post, but i used them correctly when attempting this.
    -i've done a lot of pinging, story follows next. I also tried you hosts suggestion. Good idea but it didn't work :(


    -here's the ping situation:
    Desktop -> router = works
    Desktop -> laptop = works
    Laptop -> router = works
    Laptop -> desktop = doesn't work
    Router -> Desktop = doesn't work
    Router -> Laptop = works

    I've done some packet analysis, the pings are leaving but never arriving.
    I also tried linksys tech support chat. no help there either. I restarted the router, reset the router, loaded both machines in safe-mode, did the laptop through a wired connection, situation is exactly the same.

    I also did a packet analysis of when I click on 'view workgroup computers'
    A short summary of it, .75 is desktop, .101 is laptop, .255 is obviously broadcast. I can pass along a full ethereal capture if anyone wants it.
    source dest prtcl info
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .75 -> .255 BROWSE Get Backup List Request
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .75 -> .255 BROWSE Browser Election Request
    .75 -> .255 BROWSE Get Backup List Request
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .101 -> .255 BROWSE Browser Election Request
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .101 -> .255 BROWSE Browser Election Request
    (does this a few more times)
    .101 -> .255 BROWSE Local master Announcement RIVER, Workstation, Server, Print Queue Server, NT Workstation, Potential Browser...etc
    .75 -> .255 BROWSE Get Backup List Request
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    .75 -> .255 NBNS Name query NB MSHOME<1b>
    (and it repeats with those packets a few times, .101 sends out the local master announcement once more)

    So it seems like both computers are giving shoutouts trying to see who's out there, the laptop actually said "hey this is me, this is what i can do" but nothing outside of that.

    based on a couple other checks, I also saw an arp request from laptop, and desktop responded correctly (who's got .75, tell .101; I'm .75, this is me). So packets can move between the two. They don't seem to listen to each other via broadcast though.

    Thanks a bunch for the help so far, any further ideas?
  8. AndyMan1

    AndyMan1 LI Guru Member

    OK, so after a long chat with 2nd tier tech support, I've narrowed it down to the desktop itself.

    HOW it's happening, i have no clue, but at least I know *where* it's happening.

    There's no spyware, no firewalls, no antivirus, nothing that could cause this, that i'm aware of. It's really weird.

    I guess I can try uninstalling the TCP/IP stack, after that maybe a full reinstall? *shudders*
  9. Thibor

    Thibor Super Moderator Staff Member Member

    in the router's Firewall page, UNcheck Filter Internet NAT Redirection. it interferes with network sharing. also, ensure AP Isolation is not active in Wireless_Advanced.asp
  10. AndyMan1

    AndyMan1 LI Guru Member

    WOW. I finally figured it out. Despite the fact that I had turned it off, and made sure it was off, ZoneAlarm was still running as a service, and not showing up in task manager. Uninstalled it and it works.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice