WRT54G UPnP Issues

Discussion in 'Cisco/Linksys Wireless Routers' started by hoodiejuggalo, Aug 18, 2005.

  1. hoodiejuggalo

    hoodiejuggalo Network Guru Member

    I ran the UPnPTest by Mark Gillespie, and I always fail at Test 7. I've updated my router to the lastest offical firmware, made sure UPnP was enabled in the router, still a no go. Anyone have any thoughts or ideas as to what could be causing this?
  2. hhawkman

    hhawkman Network Guru Member

    You and me both

    I was trying the same thing the last few days with no success. They say open ports 1900, and 2869 and I get basically nothing. After searching the web I also opened 5000, and 2869 at the computer, and allowed my subnet and also to talk to the ports. Best I get is having the router show up in network connections as "Disabled", and if I try to enable it or show properties, it give an error. A few minutes later it disappears. If I reboot the computer and router, I can go through it again with same results. Frustrating as hell.

    I get a bunch of these in the log (windows firewall):
    2005-08-17 22:16:38 DROP UDP 1900 1900 304 - - - - - - - RECEIVE
    2005-08-17 22:16:38 DROP UDP 1900 1900 299 - - - - - - - RECEIVE
    2005-08-17 22:16:38 DROP UDP 1900 1900 376 - - - - - - - RECEIVE

    I've also gotten a bunch of these in the past tries:
    2005-08-17 20:51:15 OPEN TCP 1167 5431 - - - - - - - - -
    2005-08-17 20:51:15 CLOSE TCP 1167 5431 - - - - - - - - -
    it's something called a PARK AGENT which I can't find much info on in english on the web with a vague reference to UPNP in german.

    I've tried going to UPNP.org, and downloading all the UPNP schemas and putting them in system32/icsxml directory with no help. What bothers me is the "DROP" in all the 1900 events above. it's like they are being rejected.

    I've turned on every service, installed practically everything in network optional components, (short of IIs), and spent days getting it all back out. (Did you know that when you uninstall IPV6 peer2peer, then uninstall it, it says it's gone, but it's still being loaded?)

    Either someone is holding back critical info or the s**t just doesn't work.

    I'm starting to think it is all a big marketing thing with no substance behind it. :)

    What is this UPNP test? I haven't heard of that yet.
  3. hhawkman

    hhawkman Network Guru Member

    OK, did some testing. I dug out my old trusty.

    BEFSR41 V2

    Swaped everything out, reset firmware to default, enabled UPNP, and it worked.

    I played around with it, and remembered why I never used UPNP.

    My bandwidth dropped from the usual 7-8 mbps, down to 4 mbps.

    There were internal packets flying at the speed of well, electrons.

    it was opening and closing ports between the router and computer around 10-12 times/second.

    2005-08-18 00:13:53 OPEN TCP 2827 6688 - - - - - - - - -
    2005-08-18 00:13:53 CLOSE TCP 2827 6688 - - - - - - - - -
    2005-08-18 00:13:53 OPEN TCP 2828 6688 - - - - - - - - -
    2005-08-18 00:13:53 CLOSE TCP 2828 6688 - - - - - - - - -

    (I'm assuming the port difference was due to the incredably old firmware (2001-2002) ) I turned off upnp on both sides, and my speed went up to 5-6 mbps.

    So that takes it back to mr WRT54G. Swapped the wires back, reset everything and still no UPNP, but my speed went back up to the 7-8 mbps range. (Witch I suppose I should have expected with the old router. That puppy ran 24/7 for almost 5 years without much of a break, and was probably trying to do the job of an AMD64 with a 386) :grin:

    Doesn't solve our problem, but was interesting at least.

    BTW, found the test you spoke of, failed same place. #7
  4. hoodiejuggalo

    hoodiejuggalo Network Guru Member

    Glad you found the test, it's helped me up to this point. This is pretty frustrating, especially after hearing it worked with your old router, even if it did slow your bandwidth. Anyone who has UPnP working correctly on their WRT54G should let us know what settings you may be using!
  5. hoodiejuggalo

    hoodiejuggalo Network Guru Member

    Well I also just tried using the latest HyperWRT firmware, hoping there may be a UPnP fix of some sort, but of course, nope!
  6. hhawkman

    hhawkman Network Guru Member

    Well, I have good news and bad news.

    1. Got it working.
    2. Not sure how I fixed it.

    Long story short. Was hit by the horse trojan. Cleaned it out, but it left a lot of feces behind. for one, I couldn't start any media player. WMP Mplayer2, and even mplayerC didn't pull up any video.

    I tried to use system restore to go back to an earlier point. Not one of my restore points worked. I tried reloading the registry from an old backup. Bang. Now I needed to do a repair install. got it working with a lot of event errors.

    Finally got the system to come up without errors. Did all the service pack updates (SP2, Etc).

    Now you have to realize, I really had gotten off of the UPNP issue, until last night, I enabled it, and it worked.

    It may have actually saved my ass. When I woke up this morning, I looked and the Router was still there in network connections, when I checked services, there was one enabled from port 1444 UDP on the lan side, to 2XXXX on the wan side. Had to go to work so I tried to trace down which service had started it. Wouldn't you know it was one of those that had everything and it's mother in there. shut it down, and when I got home tonight,Uninstalled IPV6, I did a WMI reset, and did a TCPIP reset.

    Now it seems to be gone. But the WRT54G UPNP is still going strong.

    Ask any question and I'll give you any info I can as far as what is running, Etc. :drinking:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice