WRT54G v. 3.1 and no wireless DHCP

Discussion in 'Cisco/Linksys Wireless Routers' started by pgolik, Aug 18, 2007.

  1. pgolik

    pgolik Guest

    Hi all,
    I just got a WRT54G v3.1 (used, but under warranty and supposedly tested) and I can't get wireless to work. Everything works fine using wired connections, but with wireless my clients don't get any IP from the router. I tried resets, hard-resets and restoring to factory defaults in all possible combinations, all to no avail. This happens both with the factory Linksys firmware, with HyperWRT, and dd-wrt. All security options are off, wireless clients see the AP with the signal at maximum, but they never receive anything from DHCP (tried with two different laptops and a Pocket PC PDA). The same clients work fine, including DHCP, with another WRT54G on wireless, and with my router when wired (laptops).
    Also, when a wireless client tries to get DHCP to respond, wired clients on the same router lose their connectivity - as if the client somehow drained the router's resources (even stops responding and a reboot is needed).
    Does it seem like a software/configuration problem, or should I simply exchange the thing under warranty (I re-flashed it with original Linksys FW for that)?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice