WRT54g v.3 bricked need widows installer

Discussion in 'Cisco/Linksys Wireless Routers' started by ndilo21, Mar 14, 2009.

  1. ndilo21

    ndilo21 Addicted to LI Member

    Hey guys, I accidentally installed the wrong frimware on my WRT54G v.3. It stopped working but I still had access to the router and installed the correct firmware, but the router still wouldn't work. I also tried installing some custom firmwares to no avail. Finally I installed sveasoft and when I try to log in to the router its asking for a username and password, which I don't have.

    I know there is a windows based program that I can connect directly to the router and install new firmware but I can remember what its called. Can anyone help me out?
  2. Toink

    Toink Network Guru Member

    Here's the tftp.exe however you need the correct password to upload the firmware. Set the server address to (default) and select the correct firmware.

  3. ndilo21

    ndilo21 Addicted to LI Member

    Damn, I have no idea what the password is. It was on the linksys default settings before I installed the svaesoft firmware and the password was the default admin. I've tried everything I can think of. I searched the net and couldn't find a default password for the svaesoft firmware anywhere. All I could find was a few people wiht the same question.
  4. ndilo21

    ndilo21 Addicted to LI Member

    Update: I got access to the router, but still no connection. I have the sveasoft talisman firmware installed but I still can't get internet. Apparently they changed the default password from user: blank pass: admin to user:admin pass:admin. Whin I connect an ethernet cable through the router I get an ip, but no internet connection and the wireles connection still has no internet. I'm going to try to re-install the linksys firmware but I have a feeling the internet still wont work.

    Any ideas? I still have complete access to the router over wireless, just no internet. Is that considered bricked?
  5. Toink

    Toink Network Guru Member

    If you can access the router then there's still hope :)

    Have you tried re-setting the router (30/30/30 procedure*) right after flashing to the stock firmware?

    *press the reset button for 30 secs. Then remove the power supply at the back while still pressing the reset button for 30 secs; then plug back the power at the back and press the reset button for another 30 sec.

    You should also check if you got the settings/wiring correctly configured.
  6. badassz34

    badassz34 LI Guru Member

    My WRT54G v2 also had issues after upgrading to firmware for a later hardware version. After it lost internet connectivity I tried to downgrade to previous firmware. It had limited functionality after that. It ran fine, on default settings, but the Web GUI was fried. Couldn't see any buttons or text on any of the management pages at all. Tooled with it off and on for a week and nothing good to report. Then tonight I stumbled on an old firmware upgrade utility for WRT54Gv2, FW3.somethingorother, from the linksys ftp site. I ran the exe, it replaced the firmware, and then I updated it to the latest OEM fw for the device. Now it's working like new again and, holy crap, I can use the web GUI to manage it. I hope your solution is as simple as mine wound up being.
  7. irootsk

    irootsk Addicted to LI Member

    ndilo21 - some internet providers accept connection from one MAC address only. So if you have got an internet, when you connect PC directly to the modem, then you have to clone MAC address of your PC to the router. So the router will act as ethernet card of your PC.
    What does it mean? Is it mean when you connect ethernet cable from PC to the router? Or when you connect ethernet cable from modem to the router?
  8. OldPhil

    OldPhil Addicted to LI Member

    I have not read all the posts, but have you rebooted the modem and reset the router. That should allow you to start from scratch.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice