WRT54G v1.0 4.20.6 - problems with webserver

Discussion in 'Linksys Official Firmware' started by Trung, Aug 10, 2005.

  1. Trung

    Trung Network Guru Member

    Here's my setup:

    WRT54G v1.0 (CDF1)
    Firmware 4.20.6
    1 PC on wireless, 1 laptop on wireless, 1 linux box (Fedora Core 3) on wire
    Apache2 webserver running on the linux box.

    Here's my problem:

    Prior to mucking with my router's firmware i.e. upgrading it to 4.20.6 (and perhaps resetting some settings when I shouldn't have), the webserver was working fine. Outside users (on the internet) could access my website.

    Now, they no longer can... however, the weird part is that I can get to the website internally (i.e. from my laptop and PC)... so that tells me the webserver is still working properly.

    I figure it may have to do w/ the firewall settings on my router. I tried enabling and disabling it, and I tried various combinations of of settings under the Security > Firewall tab in the router's admin page. (e.g. "Block Anonymous Internet Requests" and "Filter Internet NAT Redirection"). Nothing works. Internet users still can't get to the website.

    I also checked my Port forwarding, and it's the same as it was before. (Fwd'd all ports to, which is the linux box). I know that this must be working since the internal web requests are reaching it.

    What else am I missing???

    I bet it's something really simple and stupid and I'll be kicking myself for it...
  2. 4Access

    4Access Network Guru Member

    Did you try simply resetting the router to defaults (hold in rest button for 30sec) and then reconfiguring? Always a good idea after flashing a new firmware.

    Good luck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice