WRT54G v1.1 ADSL Modem Problem

Discussion in 'Cisco/Linksys Wireless Routers' started by cuff0rd, Jun 27, 2007.

  1. cuff0rd

    cuff0rd LI Guru Member


    I'm trying to connect my wireless router to a ZyXEL modem and having a problem... when I log on to the WRT54G thru my browser, and go to Diagnostics I can Ping successfully. However, when I try to ping thru any of my PCs connected to the router, I get an error saying "destination host unreachable" (similarly, nslookup doesn't work.)

    When I run ipconfig /all on a PC, it seems everything is correct. Using DHCP I get a correct IP address for my PC, the gateway is correctly set to, the DNS servers are set to my ISP's (earthlink) DNS servers etc... however, nothing works.

    Similarly, attempting to ping the DNS servers results in a host unreachable.

    Wireless Router: WRT54G Ver 1.1 Firmware 4.21.1
    Modem: ZyXEL Prestige 645M-UHP

    I had just upgraded the firmware last night... I was forced to "unbrick" my WRT54G (thanks to an article in this forum), it wouldn't start up and I had to unbrick it and install the latest firmware to get it to start up. So unfortunately previous settings are lost.

    Also, I have already set my ZyXEL to Bridge mode, and tested PPPoE using WinPoET on my PC (that's how I'm connected now)

    Note that I'm testing my WRT54G with a wired connection (so RTS, etc is of no effect.)

    I'm wondering if the automatic bridging on the WRT54G for the WAN connection isn't being set correctly? I'm out of ideas honestly and am not too familiar with networking... but here's the auto configuration set on the Wireless router if its of any help...

    Dest.LAN IP  Subnet Mask     Gateway      Hop   Interface 
    72.24x.2x.1      0     WAN (Internet)      0     LAN & Wireless         72.24x.2x.1  0     WAN (Internet) 
    (CODE tags for formatting)

    Where 72.24x.2x.1 is the gateway address.

    Any assistance greatly appreciated!!!
  2. Slimey

    Slimey Network Guru Member

    Are you running the stock linksys firmware? You try resetting to defaults one more time by holding down the reset button for 30 seconds and then reconfig?
  3. cuff0rd

    cuff0rd LI Guru Member

    Hi Slimey, thanks for the reply

    Yeah I've tried that many times :p. Its the latest firmware for the model, 4.21.1
  4. mstombs

    mstombs Network Guru Member

    Are you sure the modem is set for pppoe full bridge? Looks suspiciously like some half-bridge problems I have seen...
  5. cuff0rd

    cuff0rd LI Guru Member

    Hmm... well one problem I have is the limited functionality on my modem, which came with the Earthlink subscription. It only allows me to "Enable" and "Disable" bridge mode... there's a "Force selection" underneath it, but it made no difference when I'd tried it.

    How can I be sure? The modem was working previously, as mentioned I had to unbrick my router last night and since then it hasn't been working thru the router. Unfortunately, thru calls to support with Earthlink any configuration that was on my modem is now gone forever, so if it was something "special" it certainly wouldn't be there anymore, and there're only 2 pages of configuration that I can find.

    (No telnet access either, wasn't sure I tried when I posted this... but yeah, no telnet access on the modem)
  6. mstombs

    mstombs Network Guru Member

    Looking back at your first post - I wonder if its a simple as the router set in "Router" mode when it should be in "Gateway", those names always seemed wrong to me!
  7. cuff0rd

    cuff0rd LI Guru Member

    The only configuration I've changed on the router is setting the "Connection Type" to PPPoE and providing a user name and password. I don't see a place to change its mode from "Router" to "Gateway", altho I believe I do want it to act as a router anyway, which is why I set the modem to bridge mode... or am I way off?
  8. mstombs

    mstombs Network Guru Member

  9. cuff0rd

    cuff0rd LI Guru Member

    Aah, nope... it was already set to Gateway
  10. cuff0rd

    cuff0rd LI Guru Member

    installed dd-wrt and everything works fine... a problem must've happened while installing the linksys firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice