WRT54G v1.1 - anything but linksys FW hoses router

Discussion in 'Cisco/Linksys Wireless Routers' started by adkent, Jul 2, 2007.

  1. adkent

    adkent LI Guru Member

    Quite honestly, I've almost resolved myself to simply purchasing another router, but I wanted to run this one past everybody here before I spend the $$. I have a WRT54G v1.1 and have been running dd-wrt v2.3 for quite a while. Until recently.

    For whatever reason (unknown), the router went south over the weekend -- no GUI, no ping, etc. I finally resorted to TFTP upon power-up to re-flash with the original Linksys firmware (WRT54G_2.00.8_US_code.bin). Fortunately, this worked after a few tries, except for the fact that I could only connect via the WAN port (LAN ports were dead -- what gives?). I've run across this in the past and the dd-wrt firmware seemed to fix the port problem -- no clue why it happens in the first place.

    However, when I attempted to flash with the dd-wrt image (dd-wrt.v23_mini_generic.bin) via the Linksys GUI, the router became unresponsive again -- no GUI, no ping, etc.

    I've tried this cycle (Linksys --> dd-wrt) a few times, and the router only responds to the original linksys firmware at this time. Frankly, if the LAN/WAN ports weren't backwards, I'd call it a day and stick with the Linksys firmware.

    Any ideas, or is this thing a lost cause?
  2. Slimey

    Slimey Network Guru Member

  3. adkent

    adkent LI Guru Member

    Good point -- I reset to defaults prior to flashing, but not sure if I did post-flash. I'll need to check on that.
  4. adkent

    adkent LI Guru Member

    That was indeed the problem -- you can't kill this thing. I forgot the reset procedure AFTER flashing with DD-WRT.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice