WRT54G v1.1 Bricked?

Discussion in 'Tomato Firmware' started by taburete68, Dec 23, 2008.

  1. taburete68

    taburete68 Addicted to LI Member

    I guess I should have left things well enough alone. I 'upgraded' from tomato to dd-wrt a few weeks back and have not liked it. I decided to come back to tomato and now I am stuck with a router that won't respond to a ping. The lights on the front all respond like I think they should, but I get no IP address on my xp box. I've tried manually setting my IP to something on or .1.1, but that did not help. I've also tried holding reset while unplugging. Any other ideas?

  2. WRobertE

    WRobertE Addicted to LI Member

  3. az2008

    az2008 Addicted to LI Member

    I haven't bricked yet. But, I spent some time searching to learn how hard it would be to deal with it. I noted URLs that seemed useful:




    http://www.brayl.com/WRT54GL Debrick/index.htm


    You can google for "how to unbrick a wrt54g."

    What I picked up is that the common procedure is to start a ping (ping -t -w 10) as it's booting. You have about 5 seconds from the time it responds and the time it begins to bootstrap to run the tftp command to get the flash image into the router, and for it to install that image.

    I also picked up that something about shorting pin 16 of the flash chip as a last resort. I didn't investigate that option too far. It sounded like pin 16 is in different locations with different routers, and versions of the same router.

    Also, something about using a JTAG and program to burn the eprom directly. This sounded even more of a learning curve than the pin-16 thing.

    For most people, it sounds like the simultaneous ping and tftp thing works. What's happening is that your router is going past the 5-second window, bootstrapping from whatever is on it, and hanging. You just want to slip it the tomato image during that 5-second window.

  4. WRobertE

    WRobertE Addicted to LI Member

  5. taburete68

    taburete68 Addicted to LI Member

    Thanks for the info. I've tried the ping and tftp method a few times with success on the operation, but no success at reactivating the router. It's interesting to me that the router with respond to a ping fix or six times right after releasing the reset switch. I wonder if it is just a soft brick, like day old bread rather than an old fruit cake. (I guess the holidays are starting to get to me :))
  6. az2008

    az2008 Addicted to LI Member

    Did you try turning off the router. Hold down the reset button. Power on the router, continuing to hold the reset button for 30 seconds, then release it? I've read that people sometimes do that 10-20 times in a row and get their router back

    Did you try tftp'ing DD-WRT's mini (or micro, whatever it's called) version? Maybe going back to DD-WRT would help.

    I might try the official Linksys firmware if that didn't work. And then, there's a text-based router firmware. I forget the name of it. I think I read about it on the DD-WRT forums. It was sometimes referred to as a choice to get basic router functionality. No gui. All command-line configured in text files. It had a funny name like "knighthorse."

    Have you tried telneting to it? I guess if you can't ping it, you won't be able to telnet to it. But, if you could get to a command line you can do a "mtd erase linux". I read about this, and that it erases the kernal, causing the bootloader to have nothing to load, indefinitely waiting for a package.

    The next step would be to find out how to open the case and short pin 16.

    I flashed from DD-WRT (standard) to Tomato 1.23. No problems. But, after all the stories of bricking that I've read about (seems to be specific to DD-WRT), I spent two hours doing the 30-second reset, reboot, reset, reboot. Flash to Tomato. Reset, reboot. Clear NVRAM, reboot, reset, reboot.

    I probably went overboard. But, better safe than sorry.

    It sounds like there could be some old values in nvram messing up the firmware. If it successfully tftp'ed, that means it would have successfully installed the package and should have the firmware as you expect it to have. If it won't respond after boot, I can only think some leftover NVRAM values are causing it to be confused. The 30-second reboot (maybe many) should fix that. Going back to DD-WRT might fix it (since it would understand the old values left in NVRAM). Maybe the text-based firmware would be less sensitive.

    I remember seeing someone on the DD-WRT forum who's signature said he had a JTAG device and would unbrick routers for a fee.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice