WRT54G v1.1 dead after trying to update to Alchemy v1

Discussion in 'Sveasoft Firmware' started by bmcdougald, Jan 17, 2006.

  1. bmcdougald

    bmcdougald Network Guru Member

    I just tried to update my 54G v1.1 router to Alchemy v1 and I got a message stating that the "upgrade failed". I read further on this forum that Linksys firmware v4.20.07 would not allow an upgrade file over 3MB, so I downloaded v2.02.7 and presumed to install it, then upgrade to Alchemy.

    However, when I re-connected my PC to the router and pointed a browser to it, I didn't get anything after the login prompt, just a blank screen. I then "reset" the router, but now the router does nothing but continually flash the power indicator 3 times.

    What do I do now?
  2. vincentfox

    vincentfox Network Guru Member

    Recommend you follow usual "unbricking" procedures which are documented many places.

    Personally I connect to a switch first, then the WRT, and set to static IP The use of the switch guarantees that I can hit go on the tftp session whenever I want. If you connect directly to LAN on WRT and use Windows, then you need to wait until Windows says "connected" on your ethernet interface which may already be too late.

    I would consider DD-WRT "mini" version, or OpenWRT or other firmware, Alchemy is quite old now.
  3. jgxhs

    jgxhs Network Guru Member

    Don't worry it is recoverable, download this firmware wrt54g_1.42.2_fw.bin from here


    You then have to tftp it into your router as described in hairdairymaids de-bricking article. Then you will be able to upgrade via the GUI

    The command you need in windows is this.

    start -> run -> cmd -> tftp -i put c:\wrt54g_1.42.2_fw.bin

    One of the main things to understand it that when upgrading to DD-WRT you MUST use the generic version of DD-WRT if you wish to upgrade via the GUI all the other included files are for tftp only and will not work if you try to use then to upgrade via the GUI.

    If all that fails you can recover using jtag this is 100% guaranteed so long as there is no hardware faults.
  4. bmcdougald

    bmcdougald Network Guru Member

    OK, updated to Alchemy v1, but...

    I did not see the last post until after I did the following:

    1. downloaded wrt54g_2.02.7_us_code.exe
    2. reinstalled firmware from command application
    3. after installation, I logged into router and all appeared to be up and functional

    Here is where I may have gone off the reservation:

    1. Opened browser session pointed at my router
    2. Went to Administrator|Upgreade firmware
    3. Updated firmware to Alchemy v1.
    4. Got the "Success" screen
    5. Closed browser session
    6. Opened new browser session to and poof, nothing
    7. Tried pinging, nothing
    8. Tried a netstat, nothing

    Oh, but the router's power light did stopped blinking, that's a relief. <g>

    I have no idea what IP address this thing is using now. Where do I go from here.
  5. jgxhs

    jgxhs Network Guru Member

    Well it should be using I don't know why you can't ping it. Have you set your local area connection to the same subnet as the router and made sure that the local area connection default gateway is set to

    You could also try hard resetting the router with the reset button on the back doing this should make sure that the ip address is Keep the reset button pressed until the power light led flickers and after this keeping the reset button pressed for a few more seconds, about 30 seconds in total should be enough.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice