wrt54g v1.1 - nvram?

Discussion in 'Cisco/Linksys Wireless Routers' started by slin, Mar 26, 2006.

  1. slin

    slin LI Guru Member

    i flashed my wrt54g with openwrt and i was trying to modify the nvram settings for the network interfaces of the router with chillispot, but I somehow have the settings wrong and can not get back in. I have tried to connect to every port and ping it, but no luck. I have tried to allow my computer to get a dhcp address and also set at static and connect to it. I can however ping it if i do ping -t and power down and power up the router. But it only lasts for a few seconds after the bootup of the wrt54g and then after that it times back out. I think this is because my boot_wait=on... I can also therefore put a new firmware on there if i do it right when the linksys boots up. However, it still does not let me gain access to it by doing or telnet... It almost seems as if those settings that I configured are locked and it will not let me in. Another thing I did was connect pins 15 and 16 together and power on. The final thing i tried was connecting pin 16 to the left antenna as was stated on the recovery page. I thought reflashing this thing would erase all of my old stuff.... do you guys have anything else I can try. I have done everything I can think of.
  2. bluebox

    bluebox Network Guru Member

    1) Power on
    2) Wait for DMZ led to light
    3) EXACTLY when it lights hold the RESET button
    4) When DMZ starts flickering let go of button

    this will boot the unit in failsafe mode.

    Once the unit has booted you can telnet into (no matter what you had it set at before)

    At the prompt type:
    Then wait a minute or so for it to reset the file systems from scratch, when the prompt returns type
    mtd erase nvram
    And you should be back to a fresh OpenWRT setup. You can reflash with whatever you want from the OpenWRT web interface.
  3. slin

    slin LI Guru Member

    hey, thanks a lot.

    i got it going, and reflashed it with openwrt again. it works! one thing though... nothing else is installed except the preloaded apps with the firmware and i am running into trouble with it saying its running out of space when i try to install asterisk on openwrt. i am following the steps presented on this page... asterisk on openwrt... seems like a brand new reflash and executing the mtd erase nvram would have left me with tons of space. This version of asterisk is modified for this very purpose. i even tried running the
    mtd -r erase mtd4
    but it did not recognize mtd4. i am just confused on this one. i have a wrt54g v.1.1, so there should be plenty of room. any ideas on how to resolve this issue?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice