WRT54G v2.2 and GRC.COM ShieldsUp

Discussion in 'HyperWRT Firmware' started by gwheaton, Aug 30, 2006.

  1. gwheaton

    gwheaton Network Guru Member

    WRT54G v2.2 w/Firmware Version: v4.71.1, Hyperwrt 2.1b1 + Thibor15c

    using the above setup, Firewall in the router is on.

    When I do a ShieldsUp scan, (using common port scan), ports 23 and 80 show as open and the rest are closed, nothing is stealthed.

    Have tried with just the router firewall and also with Comodo Firewall beta running. nothing seems to be stealthed.
  2. Esquire

    Esquire Mesquire Staff Member Member

    Just to be sure... presumably DMZ is off?
  3. Toxic

    Toxic Administrator Staff Member

    are you port forwarding those two ports at all?

    make sure you have block wan requests enabled
  4. gwheaton

    gwheaton Network Guru Member

    Yes, DMZ is off.

    Under Firewall, the following are checked.

    Block Portscans
    Block Anonymous Internet Requests
    Filter Multicast
    Filter IDENT(Port 113)
  5. gwheaton

    gwheaton Network Guru Member

    Not using any port forwarding at all.

    See above post as to what is checked under firewall
  6. Thibor

    Thibor Super Moderator Staff Member Member

    port 23 = telnet, not ssh as originally typed(been a long day :) )
    port 80 = remote management?

    if neither of these are true, perhaps your modem is a router too and has opened these ports on your behalf. you could always try factory resetting and reconfiguring your router.
  7. gwheaton

    gwheaton Network Guru Member

    Ok, I did "Clear NVRAM, restore factory defaults" and still get the same results.
  8. gwheaton

    gwheaton Network Guru Member

    Ok, I think it is my ISP. I unhooked the router and hooked the modem directly to the computer. Shields UP still fails.

    I disconnected my ISP and Hooked up my Cell Phone and used that as my ISP and all tests passed.

    My ISP is a HighSpeed Wireless provider in my area. I live in the middle of know where and they are the only ones offering High Speed access. Could some setting on there end cause Shields Up to Fail?
  9. pablito

    pablito Network Guru Member

    Port 23 == telnet (ssh=22)

    My guess is that you're seeing the modem and not the WRT. You should try a telnet or browser connection from the outside and see what you get. I'll bet you get the config screen for your modem and not the WRT.
    just a guess though..

    (^ now I look silly, gwheaton replied during the minute I took to write my reply. :) )
  10. gwheaton

    gwheaton Network Guru Member

    LOL, I tried Telnet-ing to the IP address Shields UP tells me is my IP address and when I do, I get some type of Login Page asking me for a password.

    I tried to go to my IP address with a browser also and got a login dialog also.

    Emailed my ISP and will see what they say is going on.

    I will report back to let everyone know. Thanks all for the HELP
  11. Thibor

    Thibor Super Moderator Staff Member Member

    the odds are that a console and remote web administration are turned on in your modem. log into it, find the related settings and turn them off
  12. gwheaton

    gwheaton Network Guru Member

    Don't have the password for the MODEM. I emailed my ISP to see what they have to say.

    This is the Modem
  13. gwheaton

    gwheaton Network Guru Member

    Got the following from my ISP, so I am no longer worried. They are the one with the open ports.

    Start From MY ISP:

    The telnet login you are getting is to a router on our network.

    Your ip address is a shared ip address. We NAT (Network Address
    Translation) through a seperate router which is just behind that router.
    This router issues you the 172.16 address. After that you are issued
    another address in 192.168 range from your wireless router. There is some
    added security to this setup as intruders would have to pass through three
    different subnets to get to you.

    End of what they said:
  14. Guyfromhe

    Guyfromhe Network Guru Member

    Hehe NAT, that was my first guess :p
    Modems don't usually expose those ports to the internet.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice