WRT54g v2.2 crashes when transfering big files (wireless)

Discussion in 'HyperWRT Firmware' started by eline, Mar 4, 2005.

  1. eline

    eline Network Guru Member

    Hi All,
    I have a problem with my new WRT54g v2.2.
    I flashed with the new hyperWRT 2.1b1. After flashing: reset (30sec);
    WPA for the wireless clients after reset.
    When transfering a big file (for example 100 Mbytes) from a wireless client to a wired client then the transferspeed becomes slower; after a while the wireless connection is broken.
    From then on, connection becomes impossible (wireless); even internet connection is not possible anymore (also wired).
    The wrt54g has to be unpowered (rebooted) to get normal access again.
    When i do not work with big files, then there's no problem; internet works flawlessly wired and wireless. No hangups at all...
    What's wrong? Can somebody help me?

    Thanks! Eline.
  2. StratusFear

    StratusFear Guest

    I had the same exact problem with my v2.2. Flashed back to Linksys stock firmware, hit reset button for 30 sec, and the problem persisted. I ended up taking the router back to where I bought it and got an exchange since I thought something was wrong with the router, but now that I think about it, it only happened after I flashed HyperWRT the first time. Looks like I won't be using it on the new one :(

    To add to this, I do have a v2.0 sitting around with HyperWRT that does not exhibit this problem.
  3. Diavonex

    Diavonex Network Guru Member

    Have the same problem; revert back to official firmware 3.03.6
  4. ravn

    ravn Network Guru Member

    My 2.0 did it with the satori firmware, but not with the HyperWRT. Now I can easy transfer big files(dvd isos) without anything happens...
    Useing WPA with AES.
  5. djhpr

    djhpr Network Guru Member

  6. eline

    eline Network Guru Member

    Is upgrading to hyperwrt the problem then?
    I guess i hadn't this problem with big files with the linksys' original firmware; I mean before any upgrade.
    When 'back'grading, i have the same problem now.
    'Reset' the wrt54g (+/- 30sec) isn't a solution.
    What can i do now? Is this problem related to my hardware?
    I can't imagine everybody with hardware-version 2.2 has this problem...
    There are not many people with the same issues i see...

    I'm sure here in this forum there are experts with a helping hand.
    So please help me. I can't work with this router like now...

    Thanks anyway!

  7. muenstereifel

    muenstereifel Network Guru Member

    do you use stazic ip's? . . . linksys-support says that dhcp is causing the "crash" of the wrt.

    i hope this helpes to solve your probs . . .
  8. Rainey

    Rainey Network Guru Member

    Yes we all have this problem, just that not everyone transfers files between the PC to find it.

    Static IP is not the cure. Lets hope that linksys will fix this in a firmware update. Just look at the posts about dropped connection and you will see many are here talking about this problem. As the router reboots and all connection stop for a while until the reboot is finished. The file xfer is broken and needs to be started aging manually but it will fail again as it just don't work. Otherwise this router works good for other wireless data just not large files from the LAN to the WLAN or vs versa.

    It is not from upgrading the firmware, as my router had this problem with the stock firmware. I tried upgrading to see if it made any differance but it did not.

    Part of the problem is that the packets are fragmented so bad in the transfer, i see this in my client utility as it has a link status page and shows the packets sent and recived. They look normal until i try a file xfer, the i recive twice as many packet as i sent back and for some reason the counts are negitive when doing a file xfer. Some claim that setting the wireless->advanance-> fragment setting to 2304 for both the setting that are 2347 and 2346 helps but it don't cure the problem.
  9. maticks

    maticks Guest



    I just bought one of these linksys wireless routers its a WRT54G as well and i have the same issues.
    transfer a large file it keeps crashing, establish alot of bit torrent connections it keeps crashing.
    i went through all the different 3rd party firmwares and back to the stock firmware it kept crashing.

    Then i roled back to what it had on it to start with the old 3.01.3 firmware and now its not crashing.
    Its nice to see linksys tested the firmware before releasing it. :)

    Almost reminds me of the Dlink 200 ADSL modems that the offical fix for drop outs was to add a 10 meter phone line between the wall socket and the modem due to errors with g.lite detection.
  10. Klownicle

    Klownicle Network Guru Member

    Oh good, so its just a firmware issue, ive got this same problem, I download large files and the router appears to reset it self or crash, the wan light goes off then power flickers then its fine when power is solid again, I orignally had the .1 firmware for the offical linksys then I upgraded to HyperWRT and got the problem (love the firmware) and then I tried reverting to the new linksys firmware and still had the problem I haven't tried to revert the firmware to the orignal .1 version, will try tommarrow when I get access to it again.

    How large is this issue? You think linksys knows?
  11. darthmikey

    darthmikey Network Guru Member

    Hey guys i had the same problem but i don't know how i fixed it , i have a v2.2 wrt54g also but i think when i flashed it with hyperwrt 2.0(the stable version not beta!) and changed some settings (static ip-s) it just suddenly started working normally oh and if this helps i don't use wpa i use wep(couldn't get wpa working also very strange).I hope any of this helps guys.Good Luck!!!!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice