WRT54G v2.2 lost his brain, me clueless

Discussion in 'Cisco/Linksys Wireless Routers' started by moxxito, Jun 21, 2005.

  1. moxxito

    moxxito Network Guru Member

    Hello Forum,

    i'm posting for the first time after hours of strolling through the post finding a solution for my v2.2 firmware problems. I just got a new wrt54g v2.2 and trying to run a working firmware. Flashing so far is no problem, but after disconnecting power off an on again this beast always jumps into recovery mode (power led blinking, and dmz led blinking slow) waiting for a new tftp transfer. After reflashing i can do all the nitty gritty config stuff. Only after power loss the router is brainwashed. Any clues ?

    I tried the following firmwares:

    Hyper WRT 2.1b1-G
    Offical WRT54G_3.03.2.de.bin and WRT54GV3.0_3.03.6_US_code.bin
    Alchemy 1.0

    Funny is that if i flash the openwrt-g-freifunk-1.0.2-de.bin it seems to work. Unfortunally i don't need this feature set :(

    Hope someone can enlighten me.

  2. jzeitz

    jzeitz Network Guru Member

    you can only use tftp for firmware images that are smaller than 3 MB. The original linksys firmware, alchemy and hyperwrt are too big. you can only flash them over the http firmware upgrade interface. talisman from sveasoft is only 2,5 MB, that will work over tftp.

  3. moxxito

    moxxito Network Guru Member

    Sorry didn't mentioned that i also tried the Webinterface quite a few times. Also used the offical Linksys TFTP Upgrade Tool. AFAIK the 3MB limit is only in the unprotected recovery mode. TFTP with password also allows bigger firmwares.
    Also did a cross check with ewrt which is below 3MB, same result :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice