wrt54g v3.0 help, please

Discussion in 'Cisco/Linksys Wireless Routers' started by jaytee-sir, Nov 9, 2005.

  1. jaytee-sir

    jaytee-sir Network Guru Member

    hi guys, sorry i'm a complete noob at this right now. i've had my router for a good three months now and its been running on v 3.0. once in awhile after downloading for a while on bt at a high speed, say 200k/s, the connection just seems stop. both my laptop, which is a wireless connection, and my pc, which is connected by lan wire, won't connect on the net. i usually fix this by releasing and refreshing my addres on my router.

    now yesterday, it just totally stopped working and wouldn't get new address when i refreshed it....soi was wondering, will upgrading my firmware solve this disconnecting issue and which version should i get....and where are the downloads and stuff

    i tried to search on this site but its just overwhelming full of info which i have time sorting through

    thanks for any help.
  2. howardp6

    howardp6 Network Guru Member

    This is the partial change log for the the WRT54G v3.0:

    Linksys, A division of Cisco Systems, Inc.

    Product: WRT54G

    Classification: Firmware Release History

    Firmware Date: 8/18/2005

    Release Date: 8/25/2005

    Last Firmware Version: 4.20.7
    Firmware 4.20.7
    - Resolved issue with SecureEasySetup button delay
    - Resolved issue with SecureEasySetup overwritting current wireless settings
    - Resolved issue with not being able to disable SecureEasySetup button
    - Resolved issue with Diag light being constantly lit after upgrading to 4.20.6 on v.1 hardware
    - Resolved issue with iDefense security vulnerability
    - Resolved issue with L2TP disconnect
    - Resolved issue with SecureEastsetup long button push not resetting wireless settings

    Firmware 4.20.6
    - Resolve issues with setup wizard
    - Updated wireless security menu
    - Resolve issues with port based QoS

    Firmware 4.00.7
    - Adds SecureEasySetup push button support
    - Resolves large file transfer issues
    - Resolves issue with enabling TKIP after enabling WEP
    - Updated QoS features
    - Resolves issues with multiple Access Restrictions policies
    - Resolves issue where multicast breaks when MAC filter status changes

    Firmware version 4.00.7 is supposed to have solved the problems with large file transfers. Try limiting the number of torrents.
  3. atomictheory

    atomictheory Network Guru Member

    .........ummmm, so I have this exact same disconnect problem.


    I bought my WRT54G v2.2 about a year ago and had this problem FROM THE START.

    I have Charter cable intnernet service. My internet would work just fine for about 4 hours, then the WRT54G would drop the connection. I could still access the router from wired/wireless machines but the router had just dropped the internet connection. SO, I'd have to go under "status" and release/renew DHCP and it would reconnect to the internet. I upgraded to the latest Linksys firmware to no avail, so I gave up and disabled DHCP on the router and used it JUST as a WAP sitting under my Netgear RP-614 .

    Over Thanksgiving I bought a cheap laptop with wireless G built-in at walmart (yes, the fabled hp ze2308wm, that caused the customer riots) and so I thought, "I think I'll try to fix that Linksys router downstairs."

    I installed the latest version of Alchemy (which seems cool, I've boosted the xmit power for a better signal) and everything is nice EXCEPT I still have the SAME disconnecting problem!


    So will upgrading to linksys's newest stock firmware fix this problem with my WRT54G v2.2 ?
  4. drewhard

    drewhard Network Guru Member

    I'm using the 4.20.7 firmware right now and I have this exact same issue.

    I found a guide in another post that might help with the issue.


    it was supplied by MrBond82, he's a bit of a madman, and he really doesn't like QOS, But I do have to agree with him. QOS she is a Slut and isn't really necessary on a 4 port router.

    I would keep UPnP disabled and keep the firewall enabled but everything else he's put in that guide seems to make sense.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice