WRT54G v3 brick

Discussion in 'HyperWRT Firmware' started by horatiub, Jan 5, 2006.

  1. horatiub

    horatiub Network Guru Member

    Ok, here is the story: I have a WRT54G v3, and I tried to flash it with DD-WRT mini generic firmware. During the flashing process, an error occured, saying something like "Upgrade failed" and of course the router got screwed up. I couldn't ping, so I had to open it and short it following the instructions. I was able to get again to ping its interface, but when I go further and try to load the firmware thru tftp, it gives me an error : Timeout or something with code error. Bottom line is that I'm not able to flash it again, so this is my problem.

    Any sugestions will be greatly appreciate it.
  2. hotalot

    hotalot Guest

    Go to www.linksys.com and download the 4.20.7 .EXE firmware. It contains an utility for flashing the firmware.
    That's the way I recovered my WRT54G v3.1 from brick state.
  3. jpolous

    jpolous Guest

    Easy Debrick that worked for me

    I went to CompUSA to get a new WRTG54 just for testing.. I will replace my V1, but I inadvertently flashed the new one with the WRT54GS firmware. I could ping it, and even get a login prompt, but couldn't log in. Just on a hunch, I pulled the plug, held the reset button in while plugging it in.. and while still holding the reset button ran the linksys firmware update.. as soon as the ethernet initialized, it accepted the update and i was back in business. Now it's running fine on the correct dd-wrt firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice