WRT54G v3 - Recent problems w/WPA connection

Discussion in 'Cisco/Linksys Wireless Routers' started by mooncusser, Aug 10, 2007.

  1. mooncusser

    mooncusser LI Guru Member

    Hello all,
    My trusty WRT54G v3 has developed an issue recently with wireless connections using WPA security. I'm hoping someone will have some suggestions or confirm/deny my suspicions.

    The router has worked fine for 2+ years, but starting a few weeks ago my laptop (WinXP Pro) would drop the wireless connection (wired connection worked fine). When I try to reconnect, I re-enter the security key but it seems to fail while acquiring a network address. Windows tells me that I have limited or no connectivity, but it sees the SSID and a full-strength signal.

    Occasionally, restoring a backup of my config or simply rebooting the router and laptop will get the connection to work for a few days if I delete and reset the connection on the laptop. But the problem always comes back, sometimes in minutes, sometimes in hours or days.

    Changing the security to WEP seems to be more stable in limited testing, but it's a much weaker setup and I don't understand why WPA would suddenly become a problem. I'm also not entirely convinced that switching the security is fixing the problem, since a router restore or reboot had helped resolve the WPA connection in the past.

    I have confirmed this issue with another computer (dropped connection, unable to reconnect), so I don't think it's my laptop's wireless adapter.

    I've gotten the same result with the the latest factory firmware and HyperWRT v2.0 firmware.

    Linksys tech support was useless - couldn't grasp what I was saying that WPA had worked for 2+ years, so clearly my laptop does support it. :doh:

    Does anyone have suggestions or info to offer? I'm willing to try other firmware or any suggestions, but I'm concerned that my router is somehow getting worn out or reaching the end of its life.

    Many thanks in advance, I'd really appreciate any input you can offer.

  2. mooncusser

    mooncusser LI Guru Member


    Anyone have any ideas about this? Connection on WEP has been stable, but WPA continues to drop without explanation.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice