wrt54g v4 bricked, but it definitley seems unbrickable

Discussion in 'DD-WRT Firmware' started by crawdaddy, Dec 18, 2005.

  1. crawdaddy

    crawdaddy Network Guru Member

    I got a bundle of new v4s and I went to flashing them. Having some oddball troubles with DHCP of any type and dd-wrt v23, I decided to move back to v22, which I knew was nice and stable. Being the idiot I am and not thinking about it, I went and tried to flash v22 on a v4 router. So, it's bricked, and I tried pinging it, no success. I have heard of other ppl finding bricked routers on ips that have been used on them before, so I start pinging the old ips for it. I found it on, which is what I last had it configured as. I can ping it all day and night on that ip, but the tftp server doesn't seem to present at all, on or I get host unreachable or unable to get response from server errors. I know this thing has got to be recoverable somehow, and without cracking the thing open. any help is immensley appreciated, as I need this router for a customer.
  2. bytes2000

    bytes2000 Network Guru Member

    Check the WRT54G revival Guide

    WRT54G v4 isnt compatible with v22

    From the wiki:

    Special notes for flashing the WRT54Gv4

    Only DD-WRT version 23 or higher support the WRT54Gv4 and it does not support flashing the std or voip version of DD-WRT from the original Linksys firmware, because they limited the maximum firmware size to 3 MByte (as noted below). Thus, only the mini version of DD-WRT can be flashed initially.

    Once DD-WRT mini is installed, you can upgrade to std or voip versions. Use the *_generic.bin and the web interface when upgrading, unless the web interface is unavailable. Use tftp if the web interface is not available. The special (mini/std/voip)_wrt54g.bin file is only needed if you need to use tftp to upgrade the firmware.

    Remember to reset to factory defaults before and after every flashing.
  3. crawdaddy

    crawdaddy Network Guru Member

    as I said in a previous post, I can ping it, but can't tftp it. I am not going to open the router up, so the advanced debricking techniques don't apply to me. And coincidentally, flashing the mini version of dd-wrt won't work either, since the tftp doesn't appear to be working. Thanks for the input tho. Any other ideas?
  4. dellsweig

    dellsweig Network Guru Member

    I have a WRT54G V2 which I had flashed just about every version of DD_WRT since the first days. It had been configured as my client bridge and was working fine

    That is - until I flashed in the 12/16 build (mini). The box rebooted, LEDS came back and looked normal - I could not ping the device. I did a hard reset and could not ping it. The radio came up - I was able to 'connect' to the default linksys SSID but I could not get an address or ping an address.

    It almost looked like the WRT got an IP on a totally different network.

    I opened the case and did the reset - but still could not ping on

    The thought crossed my mind that it took the old address (was configured as but it did not respond to ping on that addr either.

    I could see the LAN LED flicker when I did the ping - the WRT looked like it was up and running!!

    I ended up doing an RMA with Linksys on this one
  5. bytes2000

    bytes2000 Network Guru Member


    Next time connect your nic to your router using an ethernet cable open a console and type: arp -a
    you will find your router MAC and IP <- you said the IP was set to something strange.

    sometimes doing a ping @ helps if nothing is shown with arp -a.
  6. sterix

    sterix Network Guru Member

    hello bytes2000,
    I'm running win xp and I opened a dos cmd window (is that what u mean by 'consol'?) and typed the 'arp -a' cmd and it complains 'unrecognised command.

    Can you elaborate on this command and how to use it coz I've seen it around and tried to use it but never been able to. Is that a linux cmd coz my wrt54g is a brick now and all its lan ports are out and I cannot communicate at all with it, so forget about telnet etc...

    Thanks for your help anyway.
  7. dellsweig

    dellsweig Network Guru Member

    I already mailed it back to Linksys for a new one!!!

    I have worked through bad flashes before - this one did not have the classic signes, all the LED's looked normal, The WLAN 'linksys' was up. Just could not get a DHCP address or ping the device. Doing the arp would have given some good info. Just from the look of things, I would have to say it was operating on a network other than 192.168.1... Even then, DHCP should have worked......
  8. bytes2000

    bytes2000 Network Guru Member

    arp is included in the standard TCP/IP package of your OS (Windows / Linux -> even in DD-WRT)

    Windows %windir%\system32
    Linux: /sbin/arp
  9. jedi69

    jedi69 Network Guru Member

    What did you have to do to get a replacement when you had opened the case and so on. Didn't the tamper evident sticker get messed up? I haven't RMA'd a router yet, but may need to in the future and am wondering how picky they are about that sticker and the warranty void issue.
  10. dellsweig

    dellsweig Network Guru Member

    My old V2 did not have a 'tamper' sticker

    As far as the RMA - went online with Linksys via chat session. Walked though all the revival stuff - resets, tftp, LED status, pings, etc.

    Finally, after a half hour of letting them drive, I asked if they would RMA it. They gave me a case number and I went online and printed my RMA..

    The said due to the fact that I did not have a receipt, I would be allowed a one time RMA curtesy.

    The new unit should be here in a couple days
  11. crawdaddy

    crawdaddy Network Guru Member

    I guess tonight I'm going to take the thing apart and try the ping 15-16 thing, or the 16 to ground. I don't want to, but I'm gonna have to if there aren't any more ideas :(
  12. Sumi

    Sumi Network Guru Member

    for tftp use the linksys original firmware.
  13. crawdaddy

    crawdaddy Network Guru Member

    well, I successfully recovered using the ping 15-16 short method. It started responding right away. I was a litlle dismayed b/c the first time I tried to tftp the firmware it timed out. I figured out that I had to do it pretty fast after it started responding to the pings...now to get my v3 back up. I think I destroyed the sautered connection to the chip the first time I tried to recover it with the pin shorting method.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice