WRT54G v4 dropping wireless connection

Discussion in 'Cisco/Linksys Wireless Routers' started by loosegroove1971, Dec 9, 2005.

  1. loosegroove1971

    loosegroove1971 Network Guru Member

    Hello all - first post.

    Using Windows XP Pro SP2.

    I just bought a WRT54G v4 router (has 'CDFA' in serial number) along with (2) WPC54G v2 wireless adapters.

    I updated the firmware of the router to the latest available at LinkSys (4.20.7). I turned on WPA as the wireless security. SSID is on and no MAC filters.

    I am up and running on the wireless adapter however, I am finding that the connection gets dropped quite frequently. I am letting Windows handle the wireless connection rather than using the Linksys software. This was advised by a Linksys tech rep.

    The previous wireless router/adapter combo I had was rock solid. It never seemed to lose a connections. It was 802.11b though so I wanted to upgrade. Plus, I wanted WPA security.

    Can anyone give me some clues as to why I keep losing wireless connection so often and how I can fix it? I understand wireless will lose connections from time to time but not this often. Plus, I'm using the wireless adapter in the same room about 3 feet from the router so I know I have a good connection.

    Please help!
  2. Esquire

    Esquire Mesquire Staff Member Member

    Try changing your settings

    Wireless channel
    Group Key Renewal to 600
    Beacon interval in Advanced wireless settings to 50
  3. sded

    sded Network Guru Member

    Place to start looking is usually your adapter

    1) Make sure you have the latest adapter software
    2) Do a site survey to be sure there are no other strong access points on/near your router channel (Use NetStumbler)
    3) When you are connected to your AP, look at the properties to make sure connect to non preferred APs is not checked, that there are no other APs in the automatic list, power saving is off. Take a look at your adapter parameters in Device Manager also.
    When the connection drops, what happens? Do you connect to something else, lose the IP, not see the router in the "wireless networks list", or ?
  4. loosegroove1971

    loosegroove1971 Network Guru Member

    Thanks for the replys.

    To answer your question sded, when I lose connection, the icon in the system tray shows a red 'X' through it. I must right-click on the icon and chose "Repair" and Windows re-established the connection. I can always see the network in the list of available networks.

    I will try the suggestions above when I get home tonight. I will also use NetStumbler to view other networks around my house.
  5. Goknicks

    Goknicks Network Guru Member

    Lost Wireless Connection every 2 minutes in WRT54GS v2

    Is this normal that I lost my wireless connection every 2 minutes. I used pingplotter to ping my router, skype and yahoo. All of them gave me the same result.

    I am using WRT54GS v2 and I installed firmware v4.70.6 - HyperWRT 2.1b1 - Thibor.

    Does anyone can help me to configure my router or this is normal?

    Also, I am using Azureus in my desktop, it is working find. However, when I use Skype via my wireless (laptop), keep losing my connection. My Skype connection keep losing, I say about every 2 minutes. I have to reconnect all the time. But when I turn-off my azureus, my skype call is working find.

    I use port 55350 with my Azureus and I forward my 55350 port to my desktop. Also I am alrealdy using Startup script:

    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    Can anyone help me with these problems?

    Thank you.....
  6. danielhaden

    danielhaden Network Guru Member

    You don't need the startup script with Thibor 201105.

    You do need to enable QOS and put your bittorrent and other P2P applications into the list on lowest priority (don't worry, that still means full speed when nothing else is going on) using application port settings. Put your connection speed in manually at 83% of the maximum, expressed in kbits. For instance, 1500kbits (158Kbytes) DSL is about 1245 or so. You can also list the MAC addresses of computers, and low speed is still maximum when nothing else is going on. Low speed is higher than unlisted.
  7. jmelcher

    jmelcher Network Guru Member

    Had EXACT same problem. I corrected it doing this and it has been rock steady on with no connection loss since:

    On Router:
    Wireless Mode: AP
    Wireless Security>
    Security Mode: WEP
    Default Transmit Key: 3
    WEP Encryption: 64bits 10hex digits
    >>may work w/128bit but since 64bit works I haven't changed it
    Passphrase: "choose a one word passphrase "
    Click Generate. Look for key in Key 3, write down for adding to laptop.

    On Laptop:
    Properties for Wireless NIC>
    Network Authorization: Open
    Data Encryption: WEP
    Network Key: key you wrote down in above Router config
    Key Index: 3

    That's it. I tried various keys, but for some reason only Key3 really worked without dropping the connection and missing pings every 2-3 minutes.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice