WRT54G v4 JTAG help needed in Windows, or other suggestions

Discussion in 'Cisco/Linksys Wireless Routers' started by Pow_2k, Nov 17, 2006.

  1. Pow_2k

    Pow_2k LI Guru Member

    So after doing a really nice install of an SD card adapter on my WRT54G v4, I managed to brick it via an incomplete flash and am now trying to recover. The unit will power on with a rapidly blinking power LED. If I set my computer to a static IP I can ping the unit at, but cannot get into it via telnet or http. TFTP times out. I have tried the different pin shorting/grounding recommendations and have not seen any changes. I'm now at what I believe is the last resort, update via JTAG. I've built a cable based on schematics found in the HairyDairyMaid guides and can confirm with my multimeter that the connections are good. I've been measuring from the pin on the DB25 connector to the solder pads just to the side of the JTAG points on the v4 board in order to confirm that my soldering to the board itself is solid. Everything looks intact and the pinout correct but when I run the application to try and communicate with the flash chip the chip model cannot be detected, with possible causes listed as the unit may not be on, JTAG not wired correctly, JTAG not plugged in or unknown flash chip. In Windows (don't have a Linux system available) the giveio.sys driver is loaded successfully according to the loaddrv.exe application. I'm using the 4.8 build of the HairyDairyMaid application ported to Windows. (wrt54g.exe) If I try disabling the auto detect and specify any of the Intel 28F320 chips (I've confirmed this is what I have on the board) the app stalls at "Clearing Watchdog."

    I'm on the verge of just buying a prebuilt JTAG cable, but since I'm adapt at soldering and following schematics I feel the cable I've already built *should* be good and therefore don't have high confidence that a cable built by other hands will get me any further. Is it possible that through Windows I could encounter PCs that don't have the proper parallel port setup for this to work? I've only attempted the JTAG connection on one PC, my next step was going to be to try it on a different computer. I've recently received the tip to try power cycling the WRT when it hangs at a step, and also to use the switch to skip clearing watchdog. Any other suggestions or input to offer?

  2. Pow_2k

    Pow_2k LI Guru Member

    Well, still couldn't get the JTAG cable to work. Tried the suggested tips I had received over at the DD-WRT.org forum, tried from other PCs as well just in case it was a hardware compatibility problem. Taking a step back I returned to what had been a fruitless attempt to get a TFTP connection to the router. After a few tries one actually took, and I got DD-WRT micro flashed. Rebooted the router, now had the web gui and telnet back and could flash to a full DD-WRT install. Surprised as hell that this worked...

    So, let's see if I can get something out of this experience. (Besides that when I'm playing around with firmwares and configs be patient enough to make sure I'm not *FLASHING* the router at the time I disconnect the network cable. Yes, that's how I killed it. File this one under "dumbass.") If after flashing or config changes the router appears non responsive to http and telnet, so long as it still has an IP address that I can ping should I be able to TFTP a new firmware to it? I don't know how many times I had attempted to do this before it finally succeeded but it sure seemed like it wasn't going to happen. In short, pingable IP = TFTP flashable?

  3. ds18s20

    ds18s20 LI Guru Member

    Yes you got it. You should be able to upload firmware with tftp
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice