WRT54G v4 lag spikes

Discussion in 'Cisco/Linksys Wireless Routers' started by alive, Dec 2, 2005.

  1. alive

    alive Network Guru Member

    I have a really annoying problem with my WRT54Gv4 router. Over wireless connection, I get "dips", "lag spikes", "black holes" - Call it whatever you want. When this happens, I do not "loose connection" - I still have the actual connection, and no network applications "disconnect".
    This problem is especially annoying when I play online games (In counter-strike, the lag spikes seem to be timed perfectly to the exact moment I see an enemy for the first time in any given round, rendering me defenceless, and thus effectively aiding my enemy in fragging me).
    Also, this problem annoys me greatly when I connect remotely to my FreeBSD server via SSH. The problem is noticeable by the very annoyng symptom of no data either reaching me or being transmitted to the server. As I type faster than I can think, I tend to get concious about my remote administration every time this happens and screw up everything on my server.

    Once every 60 seconds, the data transmit rate of my connection dips to 0kbps. This problem occurs regardless of network load. Some pictures and a ping log might help explain the problem further.

    I have tried everything.
    1. Tweaking absolutely all wireless settings, both on my recieving end, and on the routers end.

    2. Emailing Linksys Support. They suggested changing SSID and/or channel.

    3. Chatting with Linksys Support. They asked me whether I did this and did that, etc. After 2 hours of "Yeah, I've already done that. Didnt work" and "Yeah, I've taken that into account. This doesnt apply to my situation", the linksys support techie finally offered to replace my router. He asked me where I bought it, and whether I still had the reciept. After telling him where I bought it, and that I had misplaced my reciept, he stopped responding for a long time and then finally hung up on me. Despite what I had expected - I did not get a chat log sent to my email.

    4. Upgrade firmware to latest version.

    5. Replace firmware with alternative (DD-WRT v23b2).

    Final words:
    A quick google for the keywords "wrt54g ~lag ~spike" reveals that other users have the same problem.
    The purpose of this topic is to determine whether other users of the wrt54g router have the same problem, and whether this problem is restricted to the v4 of the hardware.
    Also, my troubleshooting efforts have lead me to think that the problem is either with the hardware of the wrt54g router, or with the wireless reciever (I use a WUSB54G v4).

    If you have a WRT54G router, please take a few minutes to determine if you have the same problem as me, and maybe even post a ping log/screenshot of some sort. Also, please describe the version of the router, and what you use to recieve the wireless signal.

    Thank you all in advance.
  2. NateHoy

    NateHoy Network Guru Member

    Ran for 210 seconds. At the same time, I downloaded 10MB worth of data, and I had a conference call running on my Vonage line, and BitTorrent was running on another machine, and I was surfing the web on my laptop as fast as my little mouse fingers could carry me.

    As you can see, all responses were received within 4ms, for 210 seconds.

    Unplug any cordless phone bases you have and remove the batteries from any cordless phone handsets (2.4GHz only) and try again, just in case... If you're in an apartment building, it may be a neighbor. I'm not saying it *IS* a cordless phone, but a regular drop every 60 seconds sounds like interference.

    What is your lease timeout on the router? Could they be renewing leases? 60 seconds is a SHORT lease, but it's possible to set it at that.

    If it's clocked at EXACTLY 60 seconds (+-2 seconds), and it's regular, then check the router and the computer for any events that happen every 60 secs.
  3. alive

    alive Network Guru Member

    Hah, I fixed the problem! :cheering:

    The problem, wasnt in the router, nor was it in the signal. It was the Windows Wireless Zero Config!

    After googling some more, I saw someone vaguely mentioning that they fixed this by disabling the zero config.

    If other people are having the same problem and are googling for the answer, here is the fix:
    Go to Control Panel -> Administrative Tools -> Services
    Locate the "Wireless Zero Config", disable and stop the service. Now, use the wireless connection utility provided by the manufacturer of your wireless network reciever to connect to your router.
  4. NateHoy

    NateHoy Network Guru Member

    Nice research.

    Thanks for posting your results so others can learn from it.
  5. alive

    alive Network Guru Member


    The annoyng part of all of the results I got from google, was that there were many solutions provided, but absolutely no feedback on whether the solutions worked or not.
    Naturally, as an arrogant and young techie, I always thought that everything was excellently configured at my end. That was a mistake on my part that cost me a lot of time and grief.

    So I hope that the users who are having the same problem as me, will somehow find this topic and get to fix their problem.
  6. NateHoy

    NateHoy Network Guru Member

    It wouldn't hurt to go to a few of the other discussions and post a "by the way...." post.

    There are plenty of problems caused by a local client trying to be too smart. Finding a "stronger" access point that you really don't want, etc.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice