WRT54G V5.1 can't connect WAN

Discussion in 'Cisco/Linksys Wireless Routers' started by atarax, Jul 19, 2006.

  1. atarax

    atarax Guest

    I've just a new WRT54G V5.1.
    I configure it as his old brother (WRT54G V2.2 upgraded to 3.03)
    the local routing works :smile: fine but the WAN don't :frown:

    Internet -- MODEM --(DHCP)-- WRT54G -- (DHCP) LAN (with 3 PC)

    Comparing configuration concludes to be the same (but the secure easy setup).

    The old one works fine (I'm writing this post through this one).
    The new one doesn't work ....

    Routing table of the new one doens't show anything about WAN :confused:
    the old one (V3) well .... :confused: :confused:

    Is there some modifications in the configuration procedure ?
    Do I specify manually the routing to the WAN ?
    Does the firmware be upgraded ?

    Has anyone an idea ?


  2. stortord

    stortord LI Guru Member


    I've got just the same problem. Incredible. :cool:

  3. Toxic

    Toxic Administrator Staff Member

    Are you on a cable modem?
  4. stortord

    stortord LI Guru Member

    I'm on an ADSL-modem.

    -and- after looking further into the matter, the WRT54G status page says:

    Configuration Type

    Login Type: Automatic Configuration - DHCP
    IP Address:
    Subnet Mask:
    Default Gateway:
    DNS 1:
    DNS 2:
    DNS 3:
    MTU: 1500

    And the Internet LED emmits light, however I'm still not able to get connected to the WAN. Why isn't the router routing?!

    Is it the same with you atarax?
  5. Esquire

    Esquire Mesquire Staff Member Member

    stortord, the problem could be stemmed from the fact that your Default Gateway IP address is at

    Looks like your modem has DHCP (and possibly routing). Have you tried disabling DHCP server on the router and not use it as the Default Internet Gateway (i.e., use as an Access Point)?
  6. stortord

    stortord LI Guru Member

    Thank you very much, it did not solve my problem, but it did lead to a series of fortunate events that made me think of conflicting IPs, which made me change the router's IP from to in the basic setup-window. The gateway IP in the Status-window is now and everything is working very well.

    Thanks a lot!

    Does this work for you, atarax?
  7. TextEx2

    TextEx2 LI Guru Member

    Automatic Configuration - DHCP is wrong for your setup. you are on ADSL that requires PPPoE setting in the Internet Connection Type.
  8. Esquire

    Esquire Mesquire Staff Member Member

    That may not be true. Apparently some ISP in the US do not implement DSL connections using PPPoE on the client; they behave like cable broadband - just plug and connect.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice