WRT54G V5: Broken Configuration Page (FIX)

Discussion in 'Cisco/Linksys Wireless Routers' started by bitaram, Mar 25, 2006.

  1. bitaram

    bitaram LI Guru Member

    Hey everyone,

    I registered to this site because it seems like the only place that can help me :)

    I don't know if a problem similar to this has been posted before but whenever i log on to my router config page (in any browser) i get a page that looks like this.


    i know that that's not what's supposed to show up. All this occured a short while or maybe directly after my firmware upgrade to 1.00.6.

    Does anyone have this problem? I'm sorry if this has been posted before.

    Thanks :)
  2. Toxic

    Toxic Administrator Staff Member

    have you tried a different browser? perhaps some blocking from you original browser is causing this problem. try with firefox or MSIE (which ever you dont use) to see if the problem is browser related.
  3. bitaram

    bitaram LI Guru Member

    I've tried different browsers. Opera, firefox, and IE and all come up the same.

    Thanks for the reply
  4. jgutz20

    jgutz20 Network Guru Member

    can you flash it back down to previous versions or re-flash the existing one? i've had this problem before (not with the default linksys firmware) and i ended up flashing it again which took care of the problem. I also tried different browsers and like you, it didnt work
  5. bitaram

    bitaram LI Guru Member

    i've tried going into management mode and reflashing it but it doesn't say the update was succesful. After i chose the firmware and tried to apply it, the next page only said < . I can't find an older firmware version but if somebody does can they tell me the download link?

    thanks a lot :)
  6. skullseeker

    skullseeker Guest

    i have had the same problem (broken config page for wrt54g v5. however, mine is specific to the tab "wireless" (i.e., where one configures WPA/WEP, etc.) When i click on this tab I do not see any of the sub-headings (e.g., basic wireless settings; wireless security, wireless MAC filter, etc.) Updating firmware (to v1.00.6) did not solve the problem. Nor did hours of time spent on the phone with Linksys tech support. Amazingly, as I was creating an account to make this posting, i tried typing in the into a computer connected to the WRT54g via wireless connection, and the problem is not apparent. Previously i was attempting to use a computer connected to the router via ethernet cable. Perhaps that's a solution for you - we'll see if it keeps working for me. Good luck...this appears to be a pretty buggy product...
  7. bitaram

    bitaram LI Guru Member

    i tried it from a laptop that's connected with a wirelesss card... it gave me the same result :(

    i think i got a bad flash :cry:

    EDIT: btw can anyone upload an older firmware version somewhere? i can't seem to find any older versions online.
  8. Xenomorph

    Xenomorph Network Guru Member

    my interface looked like that when i had JavaScript blocked
  9. 137946

    137946 LI Guru Member

    i had the same problem!
    Linksys suggested me to upgrade the firmware to 1.00.6 via
    tftp program, and do the hard reset.

    Here is the letter replied to me.
  10. 137946

    137946 LI Guru Member

    Now my WRT54G V.5 works well
  11. acgkplh

    acgkplh LI Guru Member

    Halleulla! :cheering: (however you spell it!)
    Thank you sooooo very much for posting this fix. I had the same problem and posted on this forum, but no one replied. Top guy for posting the mail from linksys support, I shall try what they suggest.

    Again yr a star man :rockon: . Thanks
  12. ganymaedes

    ganymaedes Guest

    Hello everyone,

    I experienced exactly the same problem as bitaram with my WRT54G v5 router. What I noticed is that the problem of the broken configuration page only occured on one computer while, at exactly the same time, all pages looked perfect on another computer.

    My conclusion is that, in my case anyway, the solution is not to be found in the router but in differences in the (browser?)settings of both computers.

    Just thought you should know.... :D
  13. Ixidor

    Ixidor LI Guru Member

    I have to agree that trying out different browsers is a good option. Isolation is the key. Besides browser settings being the possible culprit, a misconfigured firewall can also cause this. You may have access to the setup page but it may not display all the tabs. Unfortunately, if this is the case, changing browsers may not help that much. Another good way to isolate the problem would be to use a 2nd or 3rd computer to see if the problem is universal on your network. If I may just share, this trying-another-pc trick has worked a lot of times for me. Hope this helps.
  14. losl

    losl LI Guru Member

    I have the same problem but it was gone when i shutdown ZoneAlarm Pro. If you are using ZoneAlarm Pro try it again without this program (ZoneAlarm) running.

    Good luck!!

  15. DrTofu83

    DrTofu83 Network Guru Member

    I had the same trouble once ago. I've resolved it with an "hard" reset. In fact Management Mode, reload firm, restart once as the reload finished, and reload of lost rules.
    At today, I never had the same trouble. Sometimes, though, the WinXP PC connected to the only Ethernet cable used load the Config Page sluggishly. Paradoxally, the iBook connected via WLAN, using the same Firefox, remains as fast as usual. The issue "autoresolves".
  16. jbruett

    jbruett LI Guru Member

    ZoneAlarm Pro

    Does anyone have a workaround for 54G v6 of ZoneAlarm causing this problem...I am 100% sure that's what's causing it for me...which is rediculous...becuase i have the internal IP completely trusted in ZAP
  17. switched

    switched LI Guru Member

    yeah, i had the same problem, even though you configure the site in the privacy section, it still doesnt show you the complete page.

    You have to actually turn off cookie control, ad-blocking and mobile code control completely on the privacy main page tab, and not just for the site itself, then it works. pain, yes, but i dont know any other way.
  18. Truculent

    Truculent Network Guru Member

    Switching on then logging in via https fixes this.
    Hope that helps
  19. thebitsguy

    thebitsguy Guest

    Easy solution to this

    Hi, I had the same problem and figured it with a simple fix. May be this is useful to others as well.

    Go to
    Administration->Check on HTTPS access server option

    Open the page in https mode and things should be fine

  20. icemann77

    icemann77 LI Guru Member

    just the same issue in here upload the latest firmware for it. v1.00.9 and fyi for all users there. if your firmware is below v1.00.6 you must upgrade it to the latest firmware.because the firmware v1.00.0 to 1.00.1, v1.00.4 are corrupted firmwares!!!:mad: linksys knows this.but they still release the routers anyway.they even have the wrt54g v6 which does not have any new features but actually a re-package wrt54g v5.due to the fact that v5 has a lot of bad reviews on it.:thumbup:
  21. Mediamon

    Mediamon Network Guru Member

    It appears there are many different posted "solutions" for this issue :)

    It appears the commonality is Zone Alarm.

    My solution:

    In Zone Alarm's privacy settings, select the "Main" tab, under Cookies click the "custom" button, then on the "Cookies" tab under 3rd Party Cookies, UNCHECK "Remove private header information".

    I have found that applying this same setting via the "Site List" tab, for entry (green check set for "Private Header" not a red X) does NOT solve issue. Setting must be global.

    I suggest this is a Zone Alarm bug.

    I'm running Firefox 1.07 and Zone Alarm 6.1.744.001. Avoiding upgrade to ZAP 6.5.xxx version for many known reasons.
  22. hhriebe

    hhriebe Guest

    Just for the record, this same issue appears for WRT54G v8. I upgraded to v8.00.2 - same problem. The first time I did this, I could no longer access the router after doing the hard reset. After a quick exchange for a new one (thanks London Drugs!), I did it all again and still no admin pages.

    I turned off ZoneAlarm Security Suite 7.0.408 and bingo! There was my admin page! This allowed me to navigate to the Administration page and turn on https access. I restarted ZoneAlarm and accessed the router using https - everything works fine now. Obviously an incompatibility with ZoneAlarm.

    You could also try navigating to and select the right check box on the third line of controls. Might work.

    I'd say upgrading the firmware is probably not necessary unless you want the upgrade for other reasons.
  23. Soulzito

    Soulzito Guest

    Sorry to revive this topic but i have the same problem.

    My router is a WRT54G v2.2. I can ping the router over the default ip. I get the same screen that is showed in the screenshot over the first page. But TFTP get no "server response". I've already changed my ethernet card ip.

    What can I do from now?

    Thanks in advance.
  24. hftmrock

    hftmrock Guest

    I had this exact same issue.. I got that broken page on my desktop (hard wired) but on my wireless laptop I could get the webpage with no issues.

    I changed the security on the configuration page clicking https and http. Then I went to the desktop and tried to go to the configuration page with https: and it worked perfectly.
  25. Wizzer42

    Wizzer42 Addicted to LI Member

    Same problem here on my WRT54g version 2. I don't have zonealarm and I've tried switching to https but there is no way to make it save that setting. I am completely stumped here.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice