WRT54G v5 Corrupt Web GUI

Discussion in 'Cisco/Linksys Wireless Routers' started by Toxic, Apr 19, 2006.

  1. Toxic

    Toxic Administrator Staff Member

    There have been a number of reports of the Setup pages on the WRT54G v5 ( being corrupted.

    firstly try resetting the router. this is done by pressing the reset button for 5-10 seconds (with power on) then clear your web browsers cache before logging back onto

    this should fix the problem, if not you may require a newer firmware.
  2. arrigo

    arrigo LI Guru Member

    I came across with this problem too when my v5 is too busy (when P2P application is running) with official firmware or dd-wrt micro firmware. Stop the P2P application, Power off and power on the router, the setup pages become normal.
  3. Toxic

    Toxic Administrator Staff Member

    Newer firmware fixes the issue
  4. kias

    kias Guest

    I have a WRK54G [1.56.01] and I have a similar problem: I access the Web Interface but can't change any setting, it loops asking for a password. Untill yesterday never had any problem with the router.

    Tried power cicle, hard-reset, upgrade firmware (1.56.01 -> 1.56.01 as this is the only version available...).
    And nothing seems to work...

    Using the WebInterface to do the update didn't work (it would stop with a 'page not found' aroud 60%) tried the auto-update utility (said: update ok) but the problem remains...

    The Linksys NetSet utility (my last hope) keeps insisting that i am connected to the router through a wireless connection... and stops there.

    Telnet doesn't work (no connection available), tftp (gives an 'invalid password' error)...
  5. This problem started on my router after a local power outage

    I have had a Linksys WRT54G v5 for about 6 weeks.

    A few nights ago, we had a series of short power outages.

    After the outages were over, I noticed that my admin changes (WEP key,
    network name, etc.) were reset to the factory defaults (linksys, wide open).

    When I tried the admin page, the GUI looked funny -- it was missing several labels, etc. I got the latest firmware from linksys and followed the instructions for entering maintenance mode and downloading it. The instructions work up to the Apply button. After I click Apply, nothing happens for about 90 seconds, then the screen clears (except for a "<" character).

    Is my router busted for good?
  6. Toxic

    Toxic Administrator Staff Member

  7. mahojazz

    mahojazz Guest

    Hi, also experience this problem. I got it rectify by stopping p2p, wait for a while, then the web gui is up again.

    WRT54G v5 : 1:00:9:thumbup:
  8. juglugs

    juglugs LI Guru Member

    How do I update the firmware without the web GUI? I have the .bin files, but I don't know how to update it...
  9. icemann77

    icemann77 LI Guru Member

    just load the newest firmware guys. v1.00.9 it will fix that.
  10. Mediamon

    Mediamon Network Guru Member

  11. kingvj

    kingvj Network Guru Member

    For the WRK54G (1.56.01), you can do an 'ipconfig /flushdns' in the DOS and then access the setup page. To upgrade the router, check with the US f/w 1.58.03. D/l the bin file and also the tftp.exe from ftp.linksys.com/pub/network. Use the tftp to upload the bin file.

    My 2c.

    TRASTARO LI Guru Member

    with firmware 1.02 ok
  13. ruchi

    ruchi Serious Server Member

    hi thanks for your information i am new to this forum.................
  14. ka9yhd

    ka9yhd LI Guru Member

    When the WRT54G version 5 came out I bought one and I did not realize that it has VxWorks and not Linux. So I played with it and discovered that I could make voip calls but not receive them as the phone would never ring.
    I tried opening ports and even the DMZ option. Nothing worked. I tried a firmware update and I could no longer make or receive voip calls. I went round and round with Linksys tech support through email, and Linksys finally gave me a RMA authorization. I sent the version 5 back to Linksys and they sent me a WRT54GL v. 1.1 :)
  15. matthewd

    matthewd Reformed Router Member

    i have a wrt54gs v.5 .... by accident i put wrt54g firmware on my router ... my gui is now eff'd up and i can not do anything ... i have tried management mode ... nothing works ... is there anyway i can put the correct firmware on there?? i contacted linksys ... they wanted me to pay $30 ... im stuck .. all i want to do is put dd-wrt firmware on there so i can extend my wireless into my basement for my xbox360 .. .can anyone give me some help or advice?
  16. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Use tftp. There's a recent thread on how to do it in the Tomato forum.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice