WRT54G (v5) dropping connection

Discussion in 'Cisco/Linksys Wireless Routers' started by angelo99, Oct 18, 2005.

  1. angelo99

    angelo99 Network Guru Member

    :Like many others, too, I'm having problems with a linksys router. I just purchased it a couple of days ago. I'm connected to Charter's highspeed internet access (broadband). I was able to set it up ok. However, whenever I don't use the PC (connected to the router directly (wired), it drops its connection and I have to shut it off and turn it back on to be able to get Internet access again. This is majorly annoying. the firmware is up-dated. What can I do? The access to the cable network is not a problem (only have problem, when router is in between).
  2. hoever

    hoever Network Guru Member

    Monday i bought the wrt54g v5 and had the same problem. I went back to the store and got another one. This one doesn,t have te problem and is working fine. I have firmware v1.00.0 on it
  3. angelo99

    angelo99 Network Guru Member

    Changed MTU to 1444 yesterday - seems to help (so far no new drops though I can't explain why this works...
  4. angelo99

    angelo99 Network Guru Member

    Enjoyed it too early - that didn't work either. I'm about to throw the router of the window.
  5. OKMNL

    OKMNL Network Guru Member

    same problem overhere, i have version 3.1 with firmware v4.01.1
    though it only happens after, let's say an hour or so... so annoying
  6. influx

    influx Network Guru Member

    same problem here with the WRT54GS and have yet to find anything that will fix it. i've noticed it generally happens when all my computers are idle at night. it's so annoying... hopefully someone knows a fix.
  7. Shazzz

    Shazzz Network Guru Member

    try changing the beacon interval to 50...and disable frame burst...and try setting MTU to 1450...
  8. OKMNL

    OKMNL Network Guru Member

    nop, not working either

    why isn't it just working? i'm getting pretty fed up because of this mess...

    tried to install second laptop via wireless, with this one i cannot even connect to the internet.... :cry:
  9. atomictheory

    atomictheory Network Guru Member

    I bought my WRT54G v2.2 about a year ago and had this problem FROM THE START.

    I have Charter cable intnernet service. My internet would work just fine for about 4 hours, then the WRT54G would drop the connection. I could still access the router from wired/wireless machines but the router had just dropped the internet connection. SO, I'd have to go under "status" and release/renew DHCP and it would reconnect to the internet. I upgraded to the latest Linksys firmware to no avail, so I gave up and disabled DHCP on the router and used it JUST as a WAP sitting under my Netgear RP-614 .

    Over Thanksgiving I bought a cheap laptop with wireless G built-in at walmart (yes, the fabled hp ze2308wm, that caused the customer riots) and so I thought, "I think I'll try to fix that Linksys router downstairs."

    I installed the latest version of Alchemy (which seems cool, I've boosted the xmit power for a better signal) and everything is nice EXCEPT I still have the SAME disconnecting problem!

    Does ANYONE know how to fix this?
  10. drewhard

    drewhard Network Guru Member

    I have a simliar issue, I have a WRT54g v3.0 router with the 4.20.7 firmware release from linksys.com and I'm constantly having to disconnect and reconnect the router from my DSL connection, then I'm back up to normal speeds again, but my connection will grind to a crawl after a few hours (sometimes a few minutes) this happens to every system on my home network,

    If I connect one of my systems directly to the DSL modem, I connect and stay connected for days with out issue.

    there are somedays when there isn't an issue and then some days I spend reseting the router constantly until I get sick of doing it.

    I'm sure it's something to do with the router's firmware but Linksys support is useless and they swear their firmware works fine but in my expierence they seem to be really un reliable and I can't find any 3rd party firmware for the v3 series of my type of router.

    Does anyone know where I can find v3 safe firware for the WRT54G router?
  11. gaster

    gaster Network Guru Member

    I have a V3 and it's fine. It stays up for days and would go longer, but I seem to keep messing with it by trying various firmwares. I've never had any big problems with uptime no matter which tofu firmware I use or dd-wrt. Never really used stock linksys for any length of time.
  12. Mel1003

    Mel1003 Guest

    Help - Suggestions

    I have the WRT54G v.5.0 wireless router. I have a desktop computer and my laptop that I just bought, Tosheba Satellite. I have set up the router, configured all, and the internet connection drops after about 15 minutes. I have been on the phone with Toshiba - who say my laptop is configured correctly, it even shows Linksys as my wireless with "excellent" connection strength. I have been on the phone with Adelphia Cable who say that my internet strength is super and that is not the issue (I can use the internet just great w/o the router), and I have been on the phone with Linksys numerous times ( and have the service call numbers to prove it) and they say that they are configured correctly., even dowloaded the firmware. They even went as far as to suggest going and buying a new router, which I have done 3 times!!! Still same issue - internet signal drops after about 15 minutes. I am 2 seconds from tossing everything out of a second story window!! I have talked to all the computer folks I know and they say that something is obviously interfearing with the signal and suggest it might be my wireless phones. They are on the same frequency as the Router. I tried unplugging all of the phones and still no luck! Does anyone out there have any suggestions?? :sad:
  13. sded

    sded Network Guru Member

    From reading all the stuff about v5 problems

    it sounds like you need to go trade your v5 for an earlier model as was done at the beginning of this thread. Anything that doesn't have an SN starting with CDFB. There are still lots of v4s around (CDFA) and a sprinkling of earlier models.
  14. josteinsen

    josteinsen Network Guru Member

    Problems with my V5 linksys too... seems like it "hangs" after awhile and I have to unplug the power and plug it back in.

    Junk!. I use firmware version 1.00.2, but i dont _think_ this was an issue with the 1:00:1 it shipped with.. wish i had never upgraded the firmware.

    anyone have a link to the old (1.00:1) firmware?
  15. Toxic1

    Toxic1 Guest

    Got the same problem but the Firmware Version : v4.20.7

    Have made it a little better... but it should just stay connected 24/7 not only for an hour!
  16. Laser47

    Laser47 Network Guru Member

    I mean at least they can make a firmware fix, but no we are all stuck with these boxes. I hope someone releases a 3rd party firmware for v5 that will probably be the only way we will get our problems resolved.
  17. cbseven

    cbseven Guest

    I had this issue with v1.00.1 and installed the new firmware v1.00.2 to try to fix the issue - but it reamins. Don't waste your time going back to v1.00.1 if this is your only issue. It likely won't help.
  18. Laser47

    Laser47 Network Guru Member

    I got an email from linksys, they told me to enable MAC address cloning and clone a hardwired pc, and also if it didint work to try an MTU of 1400 to 1200 decreasing by incriments of 10. Ive tried the mac address cloning and im not getting the problems i used to get, but i dont think it was from cloning the MAC address.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice