WRT54G v5, help please!

Discussion in 'DD-WRT Firmware' started by cmonster, Dec 30, 2006.

  1. cmonster

    cmonster LI Guru Member

    I tried to install the firmware and finished TFTPing the dd-wrt.v23_micro_generic firmware with a complete message. Now all it does blink and it isn't rebooting itself. I'm sure it's not (fully) bricked because it still pings.

    I was veryy careful in following all the directions precisely and double checked to make sure I did it right. I'm not sure what is wrong with it. I'll greatly appreciate ANY help. It's still blinking at this moment because I'm not sure what to do with it. :(
  2. Toxic

    Toxic Administrator Staff Member

    if it still pings try installing the a new downloaded firmware again.
  3. cmonster

    cmonster LI Guru Member

    Huh, it's not pinging anymore. Not all the lights are solid, though. Is it bricked?
  4. Toxic

    Toxic Administrator Staff Member

    in the command prompt run a constant ping to the router

    ping -t

    then turn off and on the router and look to see if the router responds to the ping command once it powers back up again
  5. cmonster

    cmonster LI Guru Member

    Ok, just restarted the router and its pinging again. I tried reloading the firmware but it does the samething; flashes constantly without rebooting.

    Thanks for the help, btw. Appreciate it.
  6. sirushti878

    sirushti878 LI Guru Member

    same problem with me here.....i tried upgrading my platform to linux and i put in the linu_prep...whatever but den when i powercycled my router......i couldnt access the web based management mode.....its just blank.....but i can still ping......but i cant tftp.....help
  7. ka9yhd

    ka9yhd LI Guru Member

    Try downloading the firmware again. It is possible the file might of been corrupted during the download.
  8. jongi

    jongi Network Guru Member

    Does tftping refer to upgrading the firmware remotely?
  9. wzaatar

    wzaatar LI Guru Member

    Ok. Here is what you should do:

    1. Open two DOS windows.
    2. In the first one, do a ping -t and keep it running.
    3. In the second one, type 'tftp -i PUT dd-wrt.v23_micro_generic.bin' BUT DON'T PRESS ENTER yet. Make sure of course that the file is in the current directory.
    4. Set a static IP address on your computer (set it to, subnet mask and gateway
    5. take the power cord out of the Linksys router, wait for a few seconds and put your cursor on the 'TFTP' window.
    6. Plug the power cord back in the Linksys router, AS SOON as you see the Ping Reply, press the 'ENTER' on the TFTP window.

    This should force the image back on the device. Wait for 2-5 minutes until you get the 'tftp completed successfully' message.

    7. Wait for 30 more seconds.
    8. Power-cycle the Linksys router again (take the power cable out, and plug it back again).

    That should get you in business.


  10. sirushti878

    sirushti878 LI Guru Member

    i put the linux_prep.bin and when i power cycle my router poof!!!!! dat stupid router power light goes on blinkin....i can ping and even dat lan light is solid but i just couldnt get into management mode as the instructions which say i need to put linux_upgrade.bin but den when i go back into the web based utility.....its just blank i.e when i type in nothing comes up......i have a wrt54g v5.i put dat lan thingy also 10BaseT Half-duplex and i cant put my old firmware too coz when i tftp anything.....it just says no responses from server.....what do i do???????help????? any more information...just ask.....i would be pleased to give.....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice