WRT54G v5: HTTP server behind a router?

Discussion in 'Cisco/Linksys Wireless Routers' started by Sweeper, Oct 17, 2006.

  1. Sweeper

    Sweeper Network Guru Member

    Hi everyone,

    Here's the deal. I have a WRT54G, behind which goes a switch, and then several PCs. Let's assume that an external ISP-assigned IP address is, local PCs have addresses like,,, etc. On one of these local machines (say, I've installed an HTTP server, which requires to be seen from outside of the network.

    Now, how do I configure it on the router? So far I tried two approaches:

    1. Enabled DMZ and entered (i.e., internal server address) as the DMZ host IP address.

    2. Enabled port range forwarding to the server IP (i.e., for the HTTP port (i.e., 80), tried only TCP and both TCP/UDP.
    Neither of these works. I mean that my HTTP server is seen as [noparse][/noparse] from withing the network, but it cannot be seen as [noparse][/noparse] (i.e., via an external IP), neither from within or from outside of the network, and this is exactly what I need...

    Could anyone please advise me how to do that?

    P.S. I also checked that my firmware is the latest. Linksys website says that the latest firmware is this:

    Firmware Date: 1/17/2006
    Firmware Release Version: 1.00.6

    And the router says it has the following firmware:

    Firmware Version: v1.00.6, Jan. 20, 2006

    Version is the same, whereas the date differs. Is it the same firmware level?

    Thanks a lot in advance!
  2. Sweeper

    Sweeper Network Guru Member


    Well, news flash: I've updated the router firmware to the latest available (v1.01.0), but it didn't help.

    Any ideas?
  3. ifican

    ifican Network Guru Member

    chances are your ISP is blocking incomming port 80, most do now adays unless you pay for an upgraded or buisness account. To test have your server listen on a different port, use an arbitrary one that will not be blocked, 8000 for instance. The go to from the outside and see if it works. If it does thats exactly the problem.
  4. Sweeper

    Sweeper Network Guru Member

    ifican, thanks for your comment, but that's not my case obviously. I've tried via the following ports: 80, 8080 and 9999. Results are always the same, i.e. works on the intranet, doesn't work from the outside...

    Any ideas?
  5. ifican

    ifican Network Guru Member

    And you are sure you have the proper ports forwarded? And there is not a firewall on the host blocking the requests? If you ISP is allowing the ports you are trying and the server is listening on the specified ports, and you are forwarding correctly then there should not be any reason it does not work. Go back to step one, turn off the DMZ and just forward ports.
  6. Sweeper

    Sweeper Network Guru Member

    Yep. I even tried forwarding port range 1-65535, so I couldn't possibly miss anything. After all, it is not a very complicated procedure.

    Nope, no firewall. Not on the host, not on the router.

    Agreed. But it still doesn't. This is why I'm posting this question here in the first place.
  7. Sweeper

    Sweeper Network Guru Member

    An update

    Hi again,

    The problem is still unsolved... I contacted the official Linksys support and all that they were able to tell me was to check whether WAN IP is correct. I guess they either think I'm some kind of a moron, or just don't have anything else to say, so probably my only hope of resolving this lies with the community...

    So... anyone, any ideas? What could I try?
  8. MAS3

    MAS3 LI Guru Member

    Did you maybe try this only from within your local network ?
    If so, try what happens if you connect from another internet connection.
    I've seen a comment recently here about one not being able to create a "loopback" through the WAN port.
    This might be your problem.
    So if you have a laptop and a moblie connection, or you could connect from a neighbour's internet connection, try that.

    Another thought:

    Are you really directly connected to the internet, or is your modem also a router.
    And if so, did you do a port forward there or assign your linksys router to be a DMZ, or is it bridged ?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice